elf-dynstr-gc doesn't always build

VERIFIED FIXED

Status

SeaMonkey
Build Config
P2
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: TVL, Assigned: dougt)

Tracking

({memory-footprint})

Trunk
All
Linux
memory-footprint

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
two problems:

1. on my dell readhat oem box, glib.h is in /usr/include but glibconfig.h lives 
in /usr/lib/glib/include.  so when glib.h includes glibconfig.h it fails to find 
it with the default include path.  this probably needs to be picked off when the 
makefile is generated.

2. elf_dynstr-gc is build via SIMPLE_PROGRAM so it seems to get builds/link flags 
as such.  if you try ripping out gtk, then glib-config isn't used to build up the 
flags, and it fails to link.  the commented out rule to always include them 
probably needs to be turned on by default.

one last one, newer gccs generate so valid warnings off the source (end of 
funtions reached without return, etc.), that may need to be fixed.

Comment 1

18 years ago
1.  That problem is handled by using glib-config which is set in the GLIB_CFLAGS
variable.

2.  Why would removing gtk have any affect on glib?  They are 2 separate
programs and xpidl requires libIDL which requires glib.

Which options are you passing to configure?
(Reporter)

Comment 2

18 years ago
1. GLIB_CONFIG flags seems to be for gdk not glibc which is what glib.h is part 
of (the joys of library naming).

2. elf-dynstr-gc is built using some helps from gdk, glib-config is what's used 
to get the --libs and --cflags during make, same idea as gtk-config.  or are you 
comfusing it with something for glibc?

Comment 3

18 years ago
1. GLIB_CONFIG flags are for glib. Not glibc. Not gdk.  glib is a separeate
helper library that is used by gdk/gtk, libIDL and other programs.

2. Yes, elf-dynstr-gc is built using glib-config which comes from glib, not
gdk.  GLIB_CONFIG should be always set...unless you configured with
--disable-libIDL.  If that's the case, then the fix is fairly simple, if not,
let me know which options you are passing to configure.
(Reporter)

Comment 4

18 years ago
oops, my bad.

my configure flags are as follows:

--enable-cpp-rtti --enable-cpp-exceptions --with-gtk=no --disable-verbose-config-
defs --disable-mailnews --without-jpeg --disable-debug --enable-strip-libs --
enable-optimize --enable-elf-dynstr-gc

checking config/autoconf.mk has GLIB_CFLAGS and GLIB_LIBS both being set to 
nothing.

Comment 5

18 years ago
It sounds like you have some other problem then.  I just tried those options and
those variables are set as they should be:

GLIB_CFLAGS     = -I/usr/lib/glib/include
GLIB_LIBS       = -L/usr/lib -lglib

Can you attach both the output from running configure and the config.log file?
(Reporter)

Comment 6

18 years ago
looking at about line 5880 of configure, there's a test for redhat's Hedwig 
release.  if it is, it forces LIBIDL_CFLAGS and LIBIDL_LIBS and skips the whole 
check.  maybe GLIB is a similiar problem?  (i'll try to grab the log, etc in a 
sec)
(Reporter)

Comment 7

18 years ago
Created attachment 15079 [details]
output from a configure run
(Reporter)

Comment 8

18 years ago
Created attachment 15080 [details]
the config.log to go with the configure output
(Reporter)

Comment 9

18 years ago
ok, figured out the problem.  the check in configure for redhat Hedwig systems 
(5879) seems to be to blame.  it's forcing off the test for libIDL, but the 
entire testing for glib (5932-6201) is within the libIDL test.  I tried moving 
all of the GLIB tests out (before the libIDL checks), and all is well on my 
system (but i've manually updated my glib to 1.2.8 if that matters).  the other 
option would be to hardcode GLIB_CFLAGS and GLIB_LIBS for redhat hedwig systems.

Comment 10

18 years ago
Created attachment 15385 [details] [diff] [review]
Adding explicit glib check while avoiding duplicate checks

Updated

18 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: nsbeta3
Priority: P3 → P2

Comment 11

18 years ago
Trivial fix but still requesting nsbeta3 status so the release will have this
fix.

Updated

18 years ago
Keywords: footprint
Whiteboard: [nsbeta3+]

Comment 12

18 years ago
Fix has been checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 13

18 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.