Application specific search returns results for other applications

VERIFIED FIXED in 5.12

Status

P3
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: emoore, Assigned: davedash)

Tracking

unspecified
5.12

Details

(Whiteboard: [qa!], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4
Build Identifier: 

If I select Thunderbird as the application on the Mozilla Add-ons web site and then search for something it frequently returns add-ons for both Thunderbird and Firefox despite the fact that the web site clearly identifies itself as "Add-ons for Thunderbird".

I'm not talking about returning the wrong web page when an add-on exists for both Thunderbird and Firefox or a confusing web page for an add-on that works for both applications. I mean add-ons that are not available for Thunderbird.

For example, search for tabs. It returns 21 add-ons. The search results include

https://addons.mozilla.org/en-US/firefox/addon/10828 (New Tab King)
https://addons.mozilla.org/en-US/firefox/addon/13720/ (Inline Browser)
https://addons.mozilla.org/en-US/firefox/addon/5142 (Print All Tabs)
https://addons.mozilla.org/en-US/firefox/addon/7643 (Prevent duplicate tabs)
https://addons.mozilla.org/en-US/firefox/addon/3662 (RemoveX - tab-menu remover)
https://addons.mozilla.org/en-US/firefox/addon/7606 (Lathe2)
https://addons.mozilla.org/en-US/firefox/addon/13670 (Ebay calendar)

https://addons.mozilla.org/en-US/thunderbird/addon/10868 (Mozilla Labs - Weave Sync)
This is listed as a Thunderbird add-on but its not clear that it really is one. It seems like an add-on for Firefox 3.5 or later. 

https://addons.mozilla.org/en-US/thunderbird/addon/7607 (Blues for Peace toolbar)
It does not specify what version it supports. This is listed as a Thunderbird add-on but its not clear that it really is a Thunderbird add-on

https://addons.mozilla.org/en-US/thunderbird/addon/11642 (Ultimate-Guitar.com search plugin)
It does not specify what version it supports. This is listed as a Thunderbird add-on but its not clear it really is one.

My impression is that application specific searches aren't, and that if that bug is fixed there is still a problem due to the database incorrectly identifying some add-ons as Thunderbrid add-ons.
 


Reproducible: Always
I can reproduce. Dave Dash, can you take a look?
Assignee: nobody → dd
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Hardware: x86 → All
Priority: -- → P3
Target Milestone: --- → 5.6
Target Milestone: 5.6 → 4.x (triaged)
I think this is almost the same as bug 532988. See discussion there for possible solution.
Depends on: 532988
Everything looks fine except for:

Linky


and 

New Tab from here.

Updated

8 years ago
Duplicate of this bug: 525914
Fixed via http://github.com/jbalogh/zamboni/commits/0a21890
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [qa!]
Target Milestone: 4.x (triaged) → 5.11
(Reporter)

Comment 7

8 years ago
Much better but that search still returns

(Ultimate-Guitar.com search plugin  20090425)
https://preview.addons.mozilla.org/z/en-US/firefox/addon/11642/

I also tried searching for filter on the preview version of the web site.
https://preview.addons.mozilla.org/z/en-US/thunderbird/search/?q=filter&cat=all&lver=any&atype=0&sort=&pid=1&pp=20&lup=&advanced=

It returns several firefox/search add-ons

(guiGoog1.2b  20090825)
https://preview.addons.mozilla.org/z/en-US/firefox/addon/13915/

(עץ הדטה - חיפוש ישראלי ממוקד  20100101)
https://preview.addons.mozilla.org/z/en-US/firefox/addon/14356/

(Octoprice shopping search & comparison engine  20081030)
https://preview.addons.mozilla.org/z/en-US/firefox/addon/9431/

(Nigma Search  20090421)
https://preview.addons.mozilla.org/z/en-US/firefox/addon/11533/

(FileDigg - pdf search engine  20100108)
https://preview.addons.mozilla.org/z/en-US/firefox/addon/12373/

It looks like the only remaining problem is its still returning Firefox search add-ons when you search Thunderbird add-ons.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ok, this bug is now "Search returns search engine add-ons that aren't compatible with the current application."  -> 4.x
Assignee: dd → nobody
Target Milestone: 5.11 → 4.x (triaged)

Comment 9

8 years ago
Searching for "Tab" returns Firefox add-on with Add to Firefox button:
https://addons.mozilla.org/en-US/firefox/addon/10142/

Updated

8 years ago
Duplicate of this bug: 578755
Ah... 

http://github.com/jbalogh/zamboni/commit/915ce24
Assignee: nobody → dd
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: 4.x (triaged) → 5.12
Comment 7 and comment 9 look fixed to me.

Doing some regression-testing around search, but the fix looks good to me.

Verified FIXED.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.