text with links gets mangled when converting to italics

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Emmanuel Touzery, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091130 Thunderbird/3.0

I went to:
http://en.wikipedia.org/wiki/AVCHD

And copied the following text from the beginning of the article into a thunderbird compose window:

"AVCHD (AVC-HD, AVC HD) utilizes MPEG-4 AVC/H.264 (AVC) video compression codec and either Dolby AC-3 (Dolby Digital) or linear PCM audio compression codec."

Then I selected the text and pressed Control-I to make the text italic.

After that the selection doesn't cover the whole text anymore and the order of words in the text was changed to:

"AVCHD (AVC-HD, AVC HD) utilizes MPEG-4 AVC/H.264 (AVC) video compression codec and either Dolby AC-3linear PCM audio compression codec. (Dolby Digital) or "

And the selection is not anymore the whole text but only from the beginning to "codec.".

Reproducible: Always

Steps to Reproduce:
1. go to http://en.wikipedia.org/wiki/AVCHD
2. copy the text "AVCHD (AVC-HD, AVC HD) utilizes MPEG-4 AVC/H.264 (AVC) video compression codec and either Dolby AC-3 (Dolby Digital) or linear PCM audio compression codec." from that page
3. start a new message in thunderbird
4. paste that text
5. select that text in thunderbird
6. press control-I
Actual Results:  
the text is mangled

Expected Results:  
text would just become italics without changing the order of the words
(Reporter)

Comment 1

9 years ago
The problem does NOT occur in Safe Mode.

I have the following extensions installed:

* slovenian language spell checker (had to change the maxVersion to let it install)
* hunspell french spell checker
* lookout 1.2.8 but it's disabled not compatible with TB3.
(Reporter)

Comment 2

9 years ago
disabling both extensions and restarting thunderbird the problem still occurs. only in safe mode it does not occur.
(In reply to comment #2)
> disabling both extensions and restarting thunderbird the problem still occurs.
> only in safe mode it does not occur.

So the issue comes from a theme. If your extensions are disable the issue comes from a theme. Safe-mode disables both extensions and themes.

As you don't have the issue in safe-mode I'll close this bug as INVALID, as the issue is clearly not in TB.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

9 years ago
The only theme I have is the thunderbird default theme.

But I'll admit I might have some JS files customized somewhere in my profile. So you're probably right to close as INVALID.
(Reporter)

Comment 5

9 years ago
I confirm that if I create a clean profile the problem does not occur (even if not running in safe mode).

I have no user*.js files in my profile so I don't know what is causing this problem.
You need to log in before you can comment on or make changes to this bug.