Cannot launch multiple instances of Firefox

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Chet Sapino, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

Cannot launch multiple instances of firefox. 

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox
2. Attempt to launch another instance of it
3. Nothing happens
Actual Results:  
A second instance of firefox was not launched


This is coupled with an earlier unresolved bug I reported where exiting firefox leaves firefox.exe in memory, thereby precluding the launch of firefox until the firefox.exe instance in memory is deleted by using task manager.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.6pre) Gecko/20091130 Shiretoko/3.5.6pre

This works fine for me. Double clicking firefox.exe twice, spawns two windows.
Please give additional steps to reproduce.
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

9 years ago
I have firefox installed on three pcs and it won't launch multiple 
instances. If I launch it once and then try to launch another instance, the 
wait cursor blinks once and nothing happens. Furthermore, 80% of the time 
when it exits, it leaves a copy of firefox in memory and it won't launch at 
all until I delete it via Task Manager. This started happening about two 
weeks ago.

These are the OS's on the three computers where I Have the problem
Xp Pro
XP Home
Vista

I have the following extensions installed on all three if this is any help:

1-Clickweather V1.1.8
Ali-in-one Sidebar V 0.7.10
IE Tab V1.5.20090525
FastestFox 3.0.0
Java Quick Starter V1.0
MS .NET Framework Assistant V1.1
XMarks V3.3.2
Zone Alarm Toolbar V 1.5.53.4
ZoomFox V 0.8

It's at the point where it is unusable on all three machines. I have been 
using this product since it came out and have never had this problem. I also 
have the same problem with the new beta version.

Any suggestions?
Have you tried:

- Firefox's safe-mode to exclude extension/theme problems
- a new profile
- a clean reinstallation

http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
(Reporter)

Comment 4

9 years ago
I found out what was causing the problem. A couple of weeks ago, I updated Zone Alarm Security Suite. It installed a Zone Alarm toolbar in Firefox, as well as  IE. When I disabled it, all of the problems vanished. I had no problem with IE, just Firefox. 

I'm happy, now that it is operating correctly. I will notify Zone Alarm of my findings.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.