Status

defect
--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: seanbrennan, Unassigned)

Tracking

({hang})

Details

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.15) Gecko/2009102617 Camino/2.0 (MultiLang) (like Firefox/3.0.15)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.15) Gecko/2009102617 Camino/2.0 (MultiLang) (like Firefox/3.0.15)

Upon opening Camino, program hangs for up to 30 seconds before operating normally. This only started happening with the new Camino 2.0

Here's the Activity Monitor reports:
http://www.londonaftermidnight.com/bugs/Sample%20of%20Camino1.txt
http://www.londonaftermidnight.com/bugs/Sample%20of%20Camino2.txt
http://www.londonaftermidnight.com/bugs/Sample%20of%20Camino3.txt

Reproducible: Always

Comment 1

10 years ago
It's spending all its time reading font information.
1) Does clearing your font cache help?
2) Does Firefox have the same startup delay? (If you could test both 3.5 and 3.0 that would be ideal.)
Reporter

Comment 2

10 years ago
1. I do not know how to clear font caches. This was only a problem with the new Camino 2.0, so it seems there's some conflict there?

2. Firefox (3.5.5) does not have the start up delay, NOW (it USED to have a similar start up delay many months ago, but a recent Firefox update seems to have cured that problem- but I never use Firefox anyway).
What about Firefox 3.0.15?  Also, how many fonts do you have installed?
Keywords: hang
Reporter

Comment 4

10 years ago
I only have Firefox 3.5.5.
I have LOTS of fonts (I do graphic design).

Comment 5

10 years ago
If Firefox used to have this problem and doesn't anymore, this is probably a dup of a fixed core bug.
Reporter

Comment 6

10 years ago
I never checked what the hang was with Firefox so can't say it had the same problem as Camino now has, however it did act similarly upon startup (though the Firefox hang was at least twice as long as this new Camino hang).
(In reply to comment #4)
> I only have Firefox 3.5.5.

You can re-download a 3.0 version here:

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/3.0.15/mac/en-US/

> I have LOTS of fonts (I do graphic design).

Can you give us a rough idea (accurate to within 10%) of how many?

cl
Reporter

Comment 8

10 years ago
Fonts: about 527.
Reporter

Comment 9

10 years ago
Ok, I installed the older Firefox and it hung as it always did before updating to 3.5.5. 

Here are the Monitor Activity Reports on Firefox during the hang:
http://www.londonaftermidnight.com/bugs/Firefox1.txt
http://www.londonaftermidnight.com/bugs/Firefox2.txt

Comment 10

10 years ago
Yes, it's doing the same thing (the stack just looks off because of their symbol stripping, presumably). So this is a core issue that has been fixed in 1.9.2.

WFM unless someone wants to find the specific bug to dup to.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Reporter

Comment 11

10 years ago
Thanks for the input. But by "fixed" what do you mean exactly? 
And why am I experiencing this since updating to Camino 2.0 last week? Is there a way to fix it in Camino? Or does this require some debugging on Camino's end?
(In reply to comment #10)

> WFM unless someone wants to find the specific bug to dup to.
There has been lots of work on 1.9.2 to improve start-up time, scattered over multiple bugs. Most of the work has been done on file loading/js/etc, not only specific to reading a font-list (bug 517045 is the most relevant here). But every little bit helps.

(In reply to comment #11)
> Thanks for the input. But by "fixed" what do you mean exactly?
It means the underlying issue is fixed in a later version of Gecko (the rendering engine used by Camino, Camino uses version 1.9.0, Firefox 3.5 uses 1.9.1)

> And why am I experiencing this since updating to Camino 2.0 last week? Is there
> a way to fix it in Camino? Or does this require some debugging on Camino's end?

Camino 2 uses a different method to load a font-list at start up, as compared to Camino 1.6. That hurts a bit the startup time, more so if you have a large collection of fonts. It also depends on what page you load when Camino launches (set as 'home page' in Preferences > General, or if you have the pref set to remember the pages/tabs that were open before quiting).

Fwiw, I have a font-list of over 700 fonts installed and only sometimes see a spinning beach-ball at start up. It really depends on how many tabs I have open. If it opens with a blank page, there are absolutely not problems.

Clearing font-caches may also help a little - an utility such as 'Onyx' can do that for you:
http://www.titanium.free.fr/pgs/english.html
Reporter

Comment 13

10 years ago
Deleted the font cache using Onyx, no effect on problem. Set start up page to a blank page, still get the spinning beach ball.

Since Firefox fixed this with 3.5.5, will Camino fix it at some point?

Comment 14

10 years ago
A version of Camino based on Gecko 1.9.1 instead of 1.9.0 would have the fix.
You need to log in before you can comment on or make changes to this bug.