Closed Bug 532570 Opened 13 years ago Closed 13 years ago

"keyring doesn't contain a key" when signing-in with a differently-cased username

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
1.0 beta3

People

(Reporter: Mardak, Assigned: Mardak)

References

Details

If crypto records are created at a different time from pubkey, e.g., tabs, indexing with the pubkey uri fails because it's case sensitive.
Flags: blocking-weave1.0+
http://hg.mozilla.org/labs/weave/rev/249fe9b6ff32
Make sure username is always lowercase so that pubkey uri, storage uri, etc. are all the same no matter how the user logged in. Server needs to be wiped to make sure existing keys with other casing are removed.
Assignee: nobody → edilee
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Duplicate of this bug: 527061
Blocks: 579509
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.