Message headers are not displayed for the msgs encoded in charsets for which Unicode converters don't exist yet

VERIFIED WORKSFORME

Status

MailNews Core
Internationalization
P3
normal
VERIFIED WORKSFORME
19 years ago
9 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
** Observed with 4/20/99 Win32 build **

Using Communicator 4.51 I sent several msgs in Cyrillic.
They are received by the POP account and downloaded -- they are
there in the Inbox file itself, but the thread pane does not
show that they exist. One would think that undecodable
strings should at least show in the header pane.

Perhaps the problem is caused by there being no Unicode/KOI8-R
converter in the source. This is not confirmed since I have not
looked at other mail charsets for which the converters are not yet
ready.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M6
(Assignee)

Comment 1

19 years ago
Probably I should return the original string for the case.
This means not decoded MIME string will appear. Is this acceptable?
(Reporter)

Comment 2

19 years ago
Cyrillic mail header &bod display has been working for the
past 2 days or so. I guess the converter has gotten into the
code. The one I had sent but did not show up before in my mailbox
are now there and displayed correctly.
(Assignee)

Comment 3

19 years ago
Do we still need to fix this or not?
(Reporter)

Comment 4

19 years ago
I tried one of the charsets not included in the current build and
which can be easily tested, i.e. UTF-7.
This message with header and body in UTF-7 actually displays in
the mailbox though the proper converters are not there.

Given this fact, I'm inclined to think that this is working now.
Let me resolve this as Worksforme unless you have an objectio to it.
(Assignee)

Comment 5

19 years ago
I have no objection for resolving this.
(Reporter)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
Resolved as Worksforme and verified as such also.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.