Storing profiles in different main location under Windows Vista and 7, possibly on 2000, XP and 2003

RESOLVED DUPLICATE of bug 247973

Status

--
enhancement
RESOLVED DUPLICATE of bug 247973
9 years ago
8 years ago

People

(Reporter: grzglo.web, Unassigned)

Tracking

Trunk
All
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091202 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.1.5) Gecko/20091130 Thunderbird/3.0

Different versions of Mozilla applications uses different folders to store profiles.

Firefox 3, 3.6 and 3.7 profiles are placed under:
C:\Users\[name]\AppData\Roaming\Mozilla\Firefox\Profiles\

Thunderbird 3 profiles are placed under:
C:\Users\Administrator\AppData\Roaming\Thunderbird\Profiles

Why not put Thunderbird and SeaMonkey profiles next to Firefox profiles, under "C:\Users\[name]\AppData\Roaming\Mozilla"? 

So under Windows Vista and Windows 7 would be:

C:\Users\[name]\AppData\Roaming\Mozilla\Firefox\Profiles\
C:\Users\[name]\AppData\Roaming\Mozilla\Thunderbird\Profiles
C:\Users\[name]\AppData\Roaming\Mozilla\SeaMonkey\Profiles\
C:\Users\[name]\AppData\Roaming\Mozilla\Sunbird\Profiles\

And under Windows 2000, XP and 2003 would be:

C:\Documents and Settings\[name]\Application Data\Mozilla\Firefox\Profiles\
C:\Documents and Settings\[name]\Application Data\Mozilla\Thunderbird\Profiles\
C:\Documents and Settings\[name]\Application Data\Mozilla\SeaMonkey\Profiles\
C:\Documents and Settings\[name]\Application Data\Mozilla\Sunbird\Profiles\

Reproducible: Always

Steps to Reproduce:
1. Install Thunderbird 3.0 RC2 under Windows Vista or Windows 7 (doesn't matter if custom or standard installation mode)
2. Start Thunderbird and setup an e-mail account
3. Go to profile location, to see it isn't under Mozilla folder like Firefox profiles.
4. Looking for it might be confusing. Firefox and Thunderbird are Mozilla branded application, they both should use the same main folder to store user data "C:\Documents and Settings\[name]\Application Data\Mozilla\".

Updated

9 years ago
Whiteboard: dupeme
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
There is the same problem under Linux, profiles are setup under  "~/.mozilla/firefox" for web browser and "~/.thunderbird" (not under "~/.mozilla/thunderbird") for e-mail client.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 247973
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.