JetAudio shell extension tweaks floating point exception behavior causing crashes after using Save As... [@ _ftol2_pentium4] caused by JetAudio

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
9 years ago
5 years ago

People

(Reporter: regist70, Unassigned)

Tracking

({crash})

1.9.2 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

no visible issues after restart

Reproducible: Sometimes

Steps to Reproduce:
1. open any internet page 
2. press ctrl+s (file - save as...)
3. in opened dialog choose any file and press ctrl+x, then paste in any folder (ctrl+v) or rename any file by pressing F2
Actual Results:  
firefox crashes and shows dialog "submit bug" (don't remember exactly)
after pressing "submit" nothing happens


content of %userdocs%\Application Data\Mozilla\Firefox\Crash Reports\LastCrash:
1259865502

extensions:
ADblock+ 1.1.1
download helper 4.6.4
flashblock 1.5.11.2
flashgot 1.2.0.9
gmail notif. 0.6.4.1
minimize to tray 0.5
no script 1.9.9.11
tabmix+ 0.3.8.2

Extensions.CheckCompatibility=false
(Reporter)

Comment 2

9 years ago
73dd1563-ec9b-4eef-8dde-db8b11220502
The crash server can't find the ID, can you please generate a new one ?
(Reporter)

Comment 4

9 years ago
ok, i'll try
(Reporter)

Comment 5

9 years ago
8c7821d4-1420-4645-a306-298b0903cdca

it written on about:crashes

may be i'm doing something wrong?
(Reporter)

Comment 6

9 years ago
similar way to crash firefox:
1. opern any page
2. open dialog Save As
3. move any file to any folder 
4. close Save As dialog (with saving page or not, doesn't matter)
5. switch to another tab (ctrl+tab)

my firefox crashes in 100% cases.
last crash:

592a0e6d-7145-4b83-860b-35330a18af61	04.12.2009	23:04

Comment 7

9 years ago
probably. let's try this another way:

https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
(Reporter)

Comment 8

9 years ago
omg. looks hard. I'll try it tommorow (it's late now, 1 a.m.)
(Reporter)

Comment 9

9 years ago
Created attachment 433792 [details]
WinDbg Report
(Reporter)

Updated

9 years ago
Version: unspecified → 3.6 Branch

Updated

9 years ago
Attachment #433792 - Attachment mime type: application/octet-stream → text/plain

Comment 10

9 years ago
So, this generally means that some evil third party has attacked a field of our process. Offhand, the following libraries are from third parties and are thus suspect:

JetFlExt [D:\Autorun\JetAudio\JetFlExt.dll]
[D:\Autorun\JetAudio\JetFlExt.RUS]
JetFlExt_2ed0000

7_zip [C:\Program Files\7-Zip\7-zip.dll]

nvcpl [C:\WINDOWS\system32\nvcpl.dll]
nvshell [C:\WINDOWS\system32\nvshell.dll]
shlext [D:\autorun\miranda\Plugins\shlext.dll]

UnlockerCOM [C:\Program Files\Unlocker\UnlockerCOM.dll]

trayToolkit [C:\Documents and Settings\Constantine\Application Data\Mozilla\Firefox\Profiles\p5p19xhx.default\extensions\mintrayr@tn123.ath.cx\components\trayToolkit.dll]

prloader [C:\Program Files\KasperskyIS\prloader.dll]
prremote [C:\Program Files\KasperskyIS\prremote.dll]
shellex [C:\Program Files\KasperskyIS\shellex.dll]

--
FAULTING_IP: 
js3250!_ftol2_pentium4+c
0037ec85 f20f2c0424      cvttsd2si eax,mmword ptr [esp]

EXCEPTION_RECORD:  ffffffff -- (.exr 0xffffffffffffffff)
.exr 0xffffffffffffffff
ExceptionAddress: 0037ec85 (js3250!_ftol2_pentium4+0x0000000c)
   ExceptionCode: c00002b5
  ExceptionFlags: 00000000
NumberParameters: 1
   Parameter[0]: 00000000

BUGCHECK_STR:  APPLICATION_FAULT_STATUS_FLOAT_MULTIPLE_TRAPS

STACK_TEXT:  
0012d6f8 0032d98c 00825200 00000000 00000000 js3250!_ftol2_pentium4+0xc
0012d91c 003284e7 00825200 00825200 028a927c js3250!js_Interpret+0x4a0c [e:\builds\moz2_slave\win32_build\build\js\src\jsops.cpp @ 1143]

Please try disabling/uninstalling the items i've identified, one of them should be the culprit, once you identify which one, you should complain to its vendor.
(Reporter)

Comment 11

9 years ago
Disabled JetAufio shell extension, no crashes since 21th March.

Comment 12

9 years ago
thanks. please contact the vendor, they're misbehaving. feel free to reference this bug, if they need more information we can provide it.
Assignee: nobody → general
Severity: normal → critical
Component: General → JavaScript Engine
Keywords: crash
Product: Firefox → Core
QA Contact: general → general
Summary: firefox crashes while file operations with alredy existing files (cut/move) in dialog Save As... → JetAudio shell extension tweaks floating point exception behavior causing crashes after using Save As... [@ _ftol2_pentium4]
Version: 3.6 Branch → 1.9.2 Branch
Crash Signature: [@ _ftol2_pentium4]

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Summary: JetAudio shell extension tweaks floating point exception behavior causing crashes after using Save As... [@ _ftol2_pentium4] → JetAudio shell extension tweaks floating point exception behavior causing crashes after using Save As... [@ _ftol2_pentium4] caused by JetAudio
You need to log in before you can comment on or make changes to this bug.