All users were logged out of Bugzilla on October 13th, 2018

Firefox 3.0 updates on Ubuntu 9.10 (but not earlier) send invalid URL for updates

VERIFIED FIXED

Status

()

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: abillings, Assigned: rstrong)

Tracking

1.9.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
I noticed while testing Firefox 3.0.16 updates on Ubuntu 9.10 that Firefox 3.0 was not getting offered the update waiting in the betatest channel. Looking at the HTTP request, I see:

https://aus2.mozilla.org/update/3/Firefox/3.0/2008052912/Linux_x86-gcc3/chrome://global/locale/intl.properties/betatest/Linux%202.6.31-15-generic%20(GTK%202.18.3)/default/default/update.xml?force=1

GET /update/3/Firefox/3.0/2008052912/Linux_x86-gcc3/chrome://global/locale/intl.properties/betatest/Linux%202.6.31-15-generic%20(GTK%202.18.3)/default/default/update.xml?force=1 HTTP/1.1

For some reason, "chrome://global/locale/intl.properties" is being inserted in the locale position in the update request.

On Ubuntu 9.04, Firefox 3.0 performs the request correctly. Since Ubuntu has been inserting its extensions and home page into ALL Firefox profiles in version 9.10, I assume that this problem is caused by Ubuntu doing something bad in the profile and overriding the locale here somehow. (Thanks, Ubuntu!)
Does this happen with 3.5? I suspect this was the locale bug that existed ever since app update was created and I fixed for 3.5 (perhaps later 3.0.x as well).
(Reporter)

Comment 2

9 years ago
This worked fine with 3.0.14 and 3.0.15 on Ubuntu 9.10.

It is broken in 3.0.1 and works with 3.0.2. Nthomas says that "we switched to storing the locale in updater.ini then (bug 446527)" in Firefox 3.0.2. "They must be setting the general.useragent.locale pref with their extension(that's what we used to use for %%LOCALE%".
(Reporter)

Comment 3

9 years ago
Rob, Firefox 3.5.0 works fine. I just checked.
This is basically the same issue as bug 469760.
With this working / fixed in app update as of 3.0.2 there really isn't anything that we can do in app update to fix this further. Al, do you want to close this out or assign it to another component since there is nothing app update can do here?
(Reporter)

Comment 6

9 years ago
Resolving Fixed since this has been addressed in current releases.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Status: RESOLVED → VERIFIED

Comment 7

9 years ago
Fixed by what?  Bug 469760?  If not, this should be resolved "worksforme" instead if it's not known.
Assignee: nobody → robert.bugzilla
You need to log in before you can comment on or make changes to this bug.