Closed Bug 532864 Opened 12 years ago Closed 12 years ago

Render : a "a display:block" with several inner div generated several "a display:block"

Categories

(Firefox :: General, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 324875

People

(Reporter: ceciestuntest, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.27 Safari/532.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Classical case works fine :

input source : 

<html>
<head></head>

<body>
<a id="hello" style="display:block;background-color:#FFFF00;width:50px;margin-left:40px;" href="http://www.google.fr">
	<div>tata</div>
	<div>toto</div>
</a>
</body>

generated source :

<html><head>

</head><body>
<a id="hello" style="display: block; background-color: rgb(255, 255, 0); width: 50px; margin-left: 40px;" href="http://www.google.fr">
	<div>tata</div>
	<div>toto</div>
</a>

</body></html>



Now if we had noise between the inner divs it doesn't work :

input source :

<html>
<head>
</head>

<body>
<a id="hello" style="display:block;background-color:#FFFF00;width:50px;margin-left:40px;" href="http://www.google.fr">
	<div>tata</div>
	<!--
	put here a lot of characters ( > 200 000 chars) to add noise
	-->
	<div>toto</div>
</a>

</body>

generated source :

<html><head>

</head><body>
<a id="hello" style="display: block; background-color: rgb(255, 255, 0); width: 50px; margin-left: 40px;" href="http://www.google.fr">
	</a><div><a id="hello" style="display: block; background-color: rgb(255, 255, 0); width: 50px; margin-left: 40px;" href="http://www.google.fr">tata</a></div>
<a id="hello" style="display: block; background-color: rgb(255, 255, 0); width: 50px; margin-left: 40px;" href="http://www.google.fr">	<!--
	the > 200 000 chars noise
	-->
	</a><div><a id="hello" style="display: block; background-color: rgb(255, 255, 0); width: 50px; margin-left: 40px;" href="http://www.google.fr">toto</a></div>


</body></html>


as we can see, there are multiple <a> tag generated for each inner <div> tag.


Reproducible: Always

Steps to Reproduce:
see details
Actual Results:  
see details

Expected Results:  
see details
Reporter: are you testing this in a plain html file on your local machine or via an HTTP server?
This works ok for me, with no additional nodes generated, here is a screenshot of "view-source" and "firebug" html viewer side by side:

http://img443.imageshack.us/img443/5309/screenshot004zs.png
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 324875
You need to log in before you can comment on or make changes to this bug.