If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

fix or remove nsCRT::strdup to use the NS_ allocator

RESOLVED DUPLICATE of bug 901820

Status

()

Core
XPCOM
P2
normal
RESOLVED DUPLICATE of bug 901820
17 years ago
4 years ago

People

(Reporter: dmose, Unassigned)

Tracking

Trunk
mozilla2.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
One type signature of nsCRT::strdup() calls nsMemory::Alloc() like one would 
hope.  Another calls PL_strdup() which only uses PR_Alloc under the covers.  
This latter setup misses the memory pressure observers entirely.  scc also 
pointed out that it could also cause other problems in an embedding case where 
nsMemory::Alloc() doesn't end up calling PR_Alloc under the covers.

This also brings up the question of whether other libraries in the Mozilla code 
base (eg png, gif, jpg, zip, ldap, js) should be instrumented to somehow use 
nsMemory under the covers as well.

Updated

17 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 1

17 years ago
Saw something in one of the status reports implying that Ed might be interested 
in this.  If not, sorry for spamming you and feel free to remove yourself.
QA Contact: rayw → xpcom

Updated

8 years ago
Assignee: scc → nobody
Priority: P3 → P2
Summary: inconsistent allocator usage → fix or remove nsCRT::strdup to use the NS_ allocator
Target Milestone: --- → mozilla1.9.3
This is a mass change. Every comment has "assigned-to-new" in it.

I didn't look through the bugs, so I'm sorry if I change a bug which shouldn't be changed. But I guess these bugs are just bugs that were once assigned and people forgot to change the Status back when unassigning.
Status: ASSIGNED → NEW
Target Milestone: mozilla1.9.3 → mozilla2.0

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 901820
You need to log in before you can comment on or make changes to this bug.