Closed Bug 533224 Opened 11 years ago Closed 10 years ago

Search filter text box cursor freezes while still typing the filter, especially with large folders

Categories

(Thunderbird :: Search, defect)

x86_64
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 533865

People

(Reporter: kyferez, Unassigned)

Details

(Keywords: perf)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091130 Thunderbird/3.0

When you use the search text box, it automatically begins searching and displays a drop-down selection. This is fine, except when attempting to search in a folder that contains many thousands of emails in it. In this case, the text box cursor and program will freeze up until the search completes which often prevents you from fully entering the search phrase or will prevent you from making a correction on a typo in the search phrase. 

Reproducible: Always

Steps to Reproduce:
1.Select a mail folder with at least several thousand emails in it.
2.Select Message Body Filter or Subject Filter (happens on any filter, but is more noticeable with these)
3.Attempt to type a search phrase into the textbox that is at least 5 characters long.
4.Note that this behavior is much more noticeable if Thunderbird has just been opened. It is also more noticeable if using a slower PC, though it happens on fast PCs.
Actual Results:  
After the search completes, you can once again modify the search phrase, but it will often freeze again, though for less time.

Expected Results:  
The search filter text box input should never freeze. The searching code needs to be handled in a separate thread to prevent this.
does the activity manager or status bar at the bottom indicate indexing is in progress, or show "determining" which messages to index?  Is folder pane view in smart folder mode?

recent bugs
https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=substring;field0-0-0=short_desc;type0-0-1=substring;field0-0-1=component;type1-0-1=substring;resolution=FIXED;resolution=DUPLICATE;resolution=---;value1-0-1=PERF;chfieldto=Now;query_format=advanced;chfieldfrom=60d;value1-0-0=slow%20freez;value0-0-1=search;type0-0-0=anywordssubstr;value0-0-0=index%20search%20;field1-0-0=short_desc;product=MailNews%20Core;product=Thunderbird;field1-0-1=keywords
Keywords: perf
Summary: Search filter text box cursor freezes while still typing the filter which causes problems entering a search phrase when searching any folder that contains thousands of emails → Search filter text box cursor freezes while still typing the filter, especially with large folders
Version: unspecified → 3.0
Here I can see this behavior but is little appreciable.
It happeans here with view "All Folders" and when no indexing is in progress (and also isn't show "determining" which messages to index).

I execute the search on a folder with 3500 mail.

I think this is a by-design behavior, since the mode filters of gloda, it searches at the very moment when you insert \ delete the new letter.

I think that with folders that are large in scale, this can be entirely eliminated only if it were delegated to the user the choice of the moment when to search, as in "search all messages" mode.

I repeat however, that here on Windows 7 with 4 GB RAM, Intel Core2 Duo T5870 (both 2.0 GHz) is very little appreciable.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091206 Lightning/1.1a1pre Shredder/3.1a1pre ID:20091206032122
Folder pane is set to Smart. The Activity Manager and Status bar are idle.

Using Vista 64bit Intel Core2 Due 1.83GHz 4GB RAM clean and very responsive PC except for this behavior

Did some more testing, and have a clarification of the bug:
I have 11 email accounts, all with between a few hundred to a few thousand messages.
I am searching the combined Inbox in Smart Folders, which shows 4800 messages.
This is where I see the "freezing" the most.
believe this is a duplicate of bug 533865, whose patch should be landing soon
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 533865
You need to log in before you can comment on or make changes to this bug.