Assert in Translate StringFunctionCall::Evaluate

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: jjs, Assigned: peter.vanderbeken)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Opening the functions.xml file in a debug build causes an assert/crash when 
processing the test case for xsl:value-of select="translate(....
(Reporter)

Comment 1

18 years ago
Okay, The problem is in String::charAt() in the mozillaString wrapper. The 
TxString version returns -1 if index is out of bounds. The mozillaString 
version does not. Hence under debug, the assert occurs and bizarra characters 
get added.
Summary: Assert/Crash in Translate StringFunctionCall::Evaluate → Assert in Translate StringFunctionCall::Evaluate
(Reporter)

Comment 2

18 years ago
Created attachment 15077 [details] [diff] [review]
Patch to fix charAt to return -1 on outofbounds
(Reporter)

Updated

18 years ago
Keywords: patch

Comment 3

18 years ago
This should be assigned to Peter since this is part of the wrapper classes. 
Bugzilla tells me I am not allowed to do that. So I've added him to the CC list.
(Assignee)

Comment 4

18 years ago
Taking bug. Thanks for the patch Jus.
Keith: ask Axel to change your Bugzilla permissions.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 5

18 years ago
Hmm. Really taking over.
Assignee: kvisco → peter.vanderbeken
Status: ASSIGNED → NEW
(Assignee)

Comment 6

18 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
We haven't been verifying bugs for quite a while :-(
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.