onchange in select list doesn't fire when using context menu while selecting item with left btn

UNCONFIRMED
Unassigned

Status

()

Core
General
UNCONFIRMED
9 years ago
7 years ago

People

(Reporter: U. Bangel, Unassigned)

Tracking

9 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(status1.9.1 .11-fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

onchange not fired when opening context menu while selecting an item and still holding down left button.

Reproducible: Always

Steps to Reproduce:
1. Press and release the right mouse button while selecting an item in a select list with the left button and still holding down the left button.
2. The context menu shows up.
3. Move the mouse outside the box while still holding down left button.
4. Release left button.
5. If you left click somewhere on the page now you will see that the new item is selected in the select box and the focus is where you clicked, but no onchange event fired for the select box.


Expected Results:  
onchange should fire when select list looses focus after new item has been selected.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
(Reporter)

Comment 2

8 years ago
Created attachment 507126 [details]
Simple page might help to reproduce issue.

The issue still exists in Firefox 3.6.13 (safe-mode).
It actually only affects "select" elements with size different from 1.

I have attached a small html-file which you might use to test.

For the demo select "test2b" while keeping left button held down and clicking right button. Contextmenu shows up. Release left button somewhere outside the select box. No onchange has triggered but selected item has changed. You can click "Show Value" to see that value really has changed.
(Reporter)

Comment 3

8 years ago
Ok i checked in Firefox 4 Beta 10 and the issue has gotten even worse.

FF 4 doesn't raise the event as well, but also keeps tracking the mouse position for the select box.
If you move the cursor above the box again you can highlight other items without click at all.
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

8 years ago
Since i did test (see comment above) and the issue still exists or got worse in firefox 4 i reopened the issue.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Whiteboard: [CLOSEME 2011-1-30]

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Comment 6

7 years ago
The issie is reproducable in the advanced search page right here in the bugtracker itself:

https://bugzilla.mozilla.org/query.cgi?format=advanced

Comment 7

7 years ago
I am unable to reproduce. At step 5 the value isn't changing.

I go to a select list (i.e. this page)
I get the selection box to come up
I left click on an option and get the option dialog
I click on a value
The option dialog disappears and the value is NOT changed to the one I clicked.

Am I doing something wrong?
status1.9.1: --- → .11-fixed
Version: Trunk → 4.0 Branch
(Reporter)

Comment 8

7 years ago
I know it's a little complicated with the clicks, but the issue is still reproducable in firefox 5.

https://bugzilla.mozilla.org/query.cgi?format=advanced

Ok i go to the "Classification" box there.
Normally if i select items, the box "Product" will change it's content.

If i do this way it won't:

1. "Client Software" is selected.
2. I press and hold down the left mouse button over "Graveyard".
3. I move the mouse outside the box (left of it) while still holding down left button.
4. I press down right button and release it, context menu shows up, still holding down left button.
5. I release left button.
6a. I click left button outside the box (still left of it) to close context menu.
7a. I click on "Graveyard" in the box "Classification".
8a. demo finished

V2:
6b. I click left button on "Graveyard".
7b. demo finished

Both "Versions":

-> Selection in the box is changed without an event beeing raised and without the box "Product" adjusting it's content.

Well this page is just one example, the onchange event simply doesn't fire everywhere it's used this way!

Comment 9

7 years ago
OK - using the STR in comment 8 I am able to reproduce on Mozilla/5.0 (Windows NT 5.1; rv:9.0a1) Gecko/20110820 Firefox/9.0a1 ID:20110820030758

Also able to reproduce on SeaMonkey 2.3 so kicking to Core for additional triage

(BTW - not sure how likely a scenario this is IRL)
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: 4.0 Branch → 9 Branch
You need to log in before you can comment on or make changes to this bug.