when sorting by order of arrival, ordering is broken in a search

RESOLVED DUPLICATE of bug 297251

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 297251
9 years ago
9 years ago

People

(Reporter: matejcik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.9.1.4) Gecko/20091016 SUSE/3.5.4-1.3 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; cs-CZ; rv:1.9.1.4pre) Gecko/20090915 SUSE/3.0b4-5.4 Thunderbird/3.0b4

most of my folders are set to sort by order of arrival, descending, and show
threads.
(plainly speaking, use threading and show new messages on top)

now this all works fine and well, but whenever i search
for something using the search box on top right, the results are in ascending
order, i.e. newest on bottom. 
which is a royal pain in the [COBE]

when i turn off threads, or sort by something else, the ordering is correct.
this particular combination (order-of-arrival + threads) breaks it

Reproducible: Always

Steps to Reproduce:
1. set up a folder to sort by order of arrival, descending order (newest on top), show threads
2. search for some word, using "Subject or From" search on the top right
Actual Results:  
the messages are found and displayed in threads sorted by order of arrival, but *ascending* order, i.e. oldest on top

Expected Results:  
the ordering should be respected and messages should be sorted in descending order

this bug was present in TB 2.x and it's still there in TB3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 297251
You need to log in before you can comment on or make changes to this bug.