Closed Bug 533318 Opened 10 years ago Closed 10 years ago

OS-wide keyboard shortcut for zooming window (maximize) does not work in Firefox, does in other apps

Categories

(Firefox :: General, defect, minor)

x86
macOS
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 429824

People

(Reporter: petruzanautico, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

I've defined alt-option-X in MacOS to zoom window (maximize equivalent)
It works on every application since it's defined at OS-level, Firefox kind of recognizes this, as the shortcut shows up in Firefox's Window menu right next to the Zoom option.
But nothing happens when you hit the shortcut combination. It works for other apps, but not for Firefox.

Reproducible: Always

Steps to Reproduce:
1. Open System Preferences app
2. Go to Keyboard & Mouse
3. Go to Keyboard Shortcuts
4. Scroll all the way down
5. Under Application Keyboard Shorcuts / All Applications click on the + button to add a shortcut
6. Enter Zoom as menu title
7. Enter something as Keyboard shortcut, for example: alt-option-X
8. Click Add
9. Try shortcut with Firefox window active. ( hit alt-option-X )
10. The window should zoom (maximize)
Actual Results:  
Nothing happens

Expected Results:  
The window should zoom (maximize)
Is Bug 439071 the same issue you are describing? IIRC, Command-+ and Command-- are the defaults and you have just changed yours to alt-option-x.
That is probably broken in Firefox, just as any other user created keyboard shortcut: bug 429824.
(In reply to comment #1)
> Is Bug 439071 the same issue you are describing? IIRC, Command-+ and Command--
> are the defaults and you have just changed yours to alt-option-x.

No, that's a confusion due to a MacOS naming ambiguity, the shorcuts CMD- and CMD+ are for zooming view, I.E. like using a magnifier. 
In MacOS, "Window Zoom" means making the window bigger. Just like Window's Maximize. It's triggered by the green plus button that every window has in its top bar.

Moreover, when I type the shortcut, the window menu option highlights, meaning that the OS correctly recognizes the menu option (zoom is under window) was sent to the application, but Firefox does nothing about it.
(In reply to comment #3)

> Moreover, when I type the shortcut, the window menu option highlights, meaning
> that the OS correctly recognizes the menu option (zoom is under window) was
> sent to the application, but Firefox does nothing about it.

That matches the behaviour of bug 429824 and most of the dupes. Firefox absolutely does not know what to do with user defined keyboard shortcuts.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
You need to log in before you can comment on or make changes to this bug.