HTTP/1.1, Connection: close, and basic auth failure

VERIFIED DUPLICATE of bug 53182

Status

()

P3
normal
VERIFIED DUPLICATE of bug 53182
18 years ago
18 years ago

People

(Reporter: hume, Assigned: gagan)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This is a bit of an obscure bug:

Mozilla can not log into a passworded website using basic auth, if the site
closes the connection between the 401 Authorization required and when Mozilla
prompts for a password/tries again.  The problem seems limited to Solaris, or
perhaps Unixes in general.  I've not been able to produce this bug using a Win32
build, but have been able to do so on two different Solaris boxes against two
different webservers.

If you go to the above URL, you'll be prompted for a username and password.
Notice that in the console Mozilla will claim to have loaded the document
successfully, when it has not.  Enter the user/pass (snog/snuh) and notice that
Mozilla does nothing.  I can cause and remove this effect by adding/removing
this line from my Apache httpd.conf:

	BrowserMatch "Mozilla/5.0" nokeepalive

If you put the user/pass in the URL:
	http://snog:snuh@www.bofh.halifax.ns.ca/mozilla-test/ ...ugh
...it will load fine.
(Reporter)

Comment 1

18 years ago
And once again I forget the build ID.  This is the Solaris 2.6 nightly, build
ID 2000091921.

Comment 2

18 years ago
It's a dup of bug 53182. But here it's more acurately described.
I can reproduce it on Linux.
(Reporter)

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 53182 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.