Thunderbird crashes if Command + Left or Right Arrow is pressed while doing "Save as..." with an email attachment.

RESOLVED WONTFIX

Status

--
critical
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: elraeburn, Unassigned)

Tracking

({crash})

x86_64
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Build Identifier: Thunderbird 2.0.0.23 (20090812), MAC OSX 10.6.2 (all latest versions as of today, Dec. 8, 2009)

This bug has also been reported to Apple, but I believe it is a Thunderbird bug, not an OSX bug.  Here's what it is:  If in Thunderbird the user is presented with a dialogue box to do "Save as..." with an attachment to an email, and the user wants to change the attachment's default name, and so the user holds down the Command key and then presses either the left or right arrow key (to move the cursor to the beginning or the end of the filename field) then the moment the arrow key is pressed, Thunderbird crashes.  Sometimes OSX's rotating "wait" kaleidoscope appears before Thunderbird actually dies. I'm on OSX 10.6.2 and Thunderbird 2.0.0.23, the most recent versions of both.  The behavior is consistently repeatable.

Reproducible: Always

Steps to Reproduce:
1.  Highlight an attachment in an email message.
2.  Right click (or two-finger touch the trackpad) and click "Save as..."
3.  In the dialogue box that appears, ensure the filename field is selected, hold down the Command Key and then press the Left or Right Arrow Keys.  On my system, a very recent MacBook Pro 13", this causes Thunderbird to die immediately, and is easily repeatable.
Actual Results:  
Thunderbird crashed.

Expected Results:  
This key sequence should have merely placed the cursor at either the beginning or end of the filename field (like the Home and End keys in Windows).

I am using the theme Silvermel v.1.30, but the problem is easily reproduced with the Thunderbird default theme, v.2.0.

Note that in the "Severity" field below, crashes are considered "Critical", but I'm leaving this one at "Normal", because it doesn't affect typical activity, if the user simply remembers to move the cursor with different (albeit less efficient) key combinations.
This works for me on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0 10.5.

Eric could you try with Thunderbird 3.0 ?
Severity: normal → critical
Keywords: crash
Version: unspecified → 2.0
(Reporter)

Comment 2

9 years ago
Ludovic: I've just installed Thunderbird 3.0.  The problem does not occur with this new version.  --Eric
I'm going to mark this bug as WONTFIX as Thunderbird 2.x is a stability and security release only branch, and this doesn't occur with TB3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.