Reading News while loading new messages loses articles

RESOLVED DUPLICATE of bug 540288

Status

RESOLVED DUPLICATE of bug 540288
9 years ago
9 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5) Gecko/20091130 Thunderbird/3.0

When checking for new articles within news, if I attempt to read a new article before all the new articles have been found and loaded, then the articles that I have tried to read are blank, and remain blank for ever. It isn't simply that they are marked as read, because the are still blank if I exit Thunderbird, reload, and read 'all messages' rather than just 'unread messages'.

Reproducible: Always

Steps to Reproduce:
1. click 'get mail' to find new news articles.
2. click on a new article before all new articles have been found.
3. 
Actual Results:  
new article is blank, and remains blank even after restarting Thunderbird and reading all articles rather than just the new articles. The 'header' pane even registers how many lines the message has, but there is nothing, even when you look at the article 'source'. By nothing, I mean nothing - not even the header info.

Expected Results:  
the article should have content
Does this happen in -safe-mode (http://kb.mozillazine.org/Safe_mode) ?

Anything in Tools -> Error console ?

Do the messages reappear if you right click on the newsgroup -> Properties -> Rebuild index ?

Comment 2

9 years ago
I think I'm seeing the same or a very similar problem but I haven't been able to recreate it quite as reliably. It happens for me mostly when clicking on posts in newsgroups when tbird is still fetching news. In addition, quitting and restarting tbird *will* show the post after all.

As for your questions:
* yes, it does happen in -safe-mode
* no, nothing is in the Error console
* no, the messages do not reappear when rebuilding the index.
Okay, so we're basically caching the empty article.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 540288
You need to log in before you can comment on or make changes to this bug.