Crash when switching themes

VERIFIED WORKSFORME

Status

Core Graveyard
Skinability
P1
critical
VERIFIED WORKSFORME
17 years ago
6 years ago

People

(Reporter: Erich 'Ricky' Iseli, Assigned: Peter Trudelle)

Tracking

({crash, regression})

Trunk
x86
Windows 98
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][PDTP1][nsbeta3++])

(Reporter)

Description

17 years ago
Build ID: 2000092005

Mozilla crashes on switching themes.

Reproducibility: Every time

Steps to reproduce:
1. Start Mozilla
2. Menu View/Apply Theme/(Classic|Modern)

Actual Result: Mozilla Crashes

Expected Result: Theme should change

After restarting Mozilla, the new theme is used. Regression. Same as bug 50335
that was fixed 11 days ago.
(Reporter)

Comment 1

17 years ago
Adding keywords that apply (according to bug 50335)
Keywords: crash, nsbeta3, regression
Priority: P3 → P1
Target Milestone: --- → M18
(Reporter)

Comment 2

17 years ago
Note that switching themes works when going through
Edit|Preferences|Themes|Apply Theme

Comment 3

17 years ago
nsbeta3+. Blake, did this really just start happening today?
Whiteboard: [nsbeta3+]
(Reporter)

Comment 4

17 years ago
Phil, I am positive about that. Yesterday's build didn't have that problem.

Comment 5

17 years ago
PDT double plussing.  We'd really like our themes story to work!
Whiteboard: [nsbeta3+] → [nsbeta3+][PDTP1][nsbeta3++]
Over to trudelle. There have been problems with this menu selection. 
Assignee: ben → trudelle
(Assignee)

Comment 7

17 years ago
Worksforme, using N6 verification build 2000092005 on Win98.  Are you doing
anything else other than launching into Navigator and switching?
(Assignee)

Comment 8

17 years ago
Can't reproduce this in today's mozilla verification build on Win98 either.

Comment 9

17 years ago
this wfm in 2000092005 win98...
(Reporter)

Comment 10

17 years ago
Sorry for this wrong alert. I don't know what happened. Yesterday, I actually
_did_ check this several times and always crashed. Today it's working just
perfect.... Maybe because I turned off my computer or because I slept over it??
Marking Invalid.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Assignee)

Comment 11

17 years ago
No need to apologize, we've all filed bugs that other folks couldn't reproduce,
that doesn't make them invalid though.  Please reopen if you see it again.
(Reporter)

Comment 12

17 years ago
This still happens intermittently. Also with today's build (ID 2000092108).
Reopening.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 13

17 years ago
How often? What are the steps to reproduce?

Comment 14

17 years ago
I don't know where else to go with this.  I can't reproduce this at all with
today's builds on win98.  Erich, could you please try it in a talkback build and
post the talkback incident ID?  Thanks.

Asa or Sarah, do you see this?

Comment 15

17 years ago
Not seeing this with recent builds.

Comment 16

17 years ago
marking this WFM for now.

Erich: please delete mozregistry.dat and mozver.dat in C:\WINDOWS, your Users50 
(profiles) dir in C:\WINDOWS\Application Data\Mozilla, and your current build, 
and try this again in a new talkback-enabled nightly build.  If you _still_ see 
the problem, please reopen this bug and provide a talkback incident ID of the 
crash.  Thanks.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 17

17 years ago
ack, marked this fixed by accident.  reopening/marking wfm, sorry for spam.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 18

17 years ago
marking wfm
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 19

17 years ago
marking verified per build on today's win98, and per asa and trudelle's 
inability to reproduce...
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.