Closed Bug 533560 Opened 10 years ago Closed 10 years ago

Volume control does not control zoom level

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

Other
Linux
defect
Not set

Tracking

(status1.9.2 .4-fixed)

VERIFIED FIXED
Tracking Status
status1.9.2 --- .4-fixed

People

(Reporter: drew.freyman, Assigned: mfinkle)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Fennec beta 5

Unable to zoom in or zoom out using the volume control buttons.

Reproducible: Always

Steps to Reproduce:
1.open page
2.operate volume control
3.no zoom but volume indicator appears.  volume goes up or down.
Actual Results:  
volume up = volume up
volume down = volume down

Expected Results:  
volume up = zoom in 
volume down = zoom out

Fennec beta 5
Nokia n900
firmware version v1.2009.42.11
zoom functionality has a hard keyboard input of ctrl + up or down. resolving as invalid.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
we want this functionality.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
I still don't think we want it
for the record, neither do I
I can not use CTRL +/- or CTRL up/down, since I am on a Swedish/Finnish keyboard. Please provide this option for your non English speaking users.

Double clicking to zoom in and out is my only option right now, since the zoom gesture from MicroB is missing as well. The double click is nice and usually gets me what I want, but definitely not always.
Component: General → Panning/Zooming

I confirm, Ctrl +/- or Ctrl up/down is impossible with scandinavian keyboard in N900.

Volume keys are sometimes  needed for what they a meant for, for example if there is a audio or video media embedded on the web page. 

Screwing IN and OUT works pretty good in N900 MicroB, so would not hurt to have it in Fennec either both in single- and multitouch-configurations.

I wish for example in N900, in the device menu (short power button press) would give ZoomIN and ZoomOut virtual buttons (which could query if the application on the foreground supports DBus ZoomIN and ZoomOUT commands and send a command through DBus, or if not, would send a keyboard sequence of Ctrl+I (zoomIN) or Ctrl+O (zoomOUT) which application then could choose to react to or not.

I humbly propose, Ctrl+I would be Zoom IN, and Ctrl+O would be Zoom OUT.
I'd like this "draft standard" to propagate also to Firefox PC-version and in fact to every desktop system and GUI-application. Currently Ctrl+I in Firefox is "Page Info" though, so it should be changed.

Like Ctrl+A (select all), Ctrl+X (cut), Ctrl+C (copy), Ctrl+V (paste), ZoomIN and ZoomOUT should have shortcuts which are easy to type in most of the keyboards, and without needing to press more than two buttons at the same time. If the mentioned de facto standard clipboard shortcuts are easy to give, so would be Ctrl+I and Ctrl+O. Additionally Ctrl+I/O would be easy to remember (zoom IN and OUT). Plus the "I" and "O" are side by side in the qwerty-keyboard.
There could be somehow two modes (as talked in the bug 478038), concerning volume keys, in which in normal mode volume keys would control the audio volume, but when Fennec would be put into a "zooming-mode", there would be a semitransparent hint window to show the zooming-factor (%) and hardware volume keys would tune also zooming factor.  On the touch screen devices there would also be semitransparent touch button widgets for zoom-in and zoom-out. 
In this zooming mode, all devices with a physical/virtual keyboard could map 'I' and 'O' as a zoom-in and zoom-out without the CTRL key.
After the "zooming-mode" is exited, the volume keys again just control the system sound volume and 'I' and 'O'-keys would need CTRL again to zoom.

I understood from the bug 478038, it is however challenging for Fennec to disable even temporarly the normal function of the HW volume keys which tune the system audio volume, for example if there is musicplayer playing on the background process. And Nokia has a guideline for N900 not to use volume keys for anything else?

(Right now I am using MicroB still, because Fennec's zooming options are unusable. The smart zoom doesn't always work and keyboard zooming shortcuts are not practically possible in a Scandinavian N900 keyboard. I would remind, there can be devices like wrist watches or something later, which also do not have arrow keys in their minimal qwerty-keyboard.)
Attached patch patch (platform)Splinter Review
This patch is for mozilla-192 and handles releasing the volume up/down hardware key from the Maemo daemon.
Assignee: nobody → mark.finkle
Attachment #435680 - Flags: review?(dougt)
Not, the platform patch is applied over the patch in bug 541015
Attached patch patch (browser)Splinter Review
Simple browser patch that re-adds the F7 / F8 keys to handle the hardware volume keys.
Attachment #435681 - Flags: review?(21)
Attachment #435680 - Flags: review?(dougt) → review+
Attachment #435680 - Flags: approval1.9.2.3?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #435680 - Flags: approval1.9.2.4? → approval1.9.2.4+
pushed to m-192:
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/4ff8c6c17e43
Status: NEW → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.3pre) Gecko/20100402 Namoroka/3.6.3pre Fennec/1.1a2pre

and

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.3a4pre) Gecko/20100402 Namoroka/3.7a4pre Fennec/1.1a2pre

litmus testcase https://litmus.mozilla.org/show_test.cgi?id=7522 updated to regression test this bug.
Status: RESOLVED → VERIFIED
Flags: in-litmus+
You need to log in before you can comment on or make changes to this bug.