Assert on startup w/ debug jemalloc build

RESOLVED DUPLICATE of bug 526152

Status

Firefox for Android Graveyard
General
--
critical
RESOLVED DUPLICATE of bug 526152
9 years ago
8 years ago

People

(Reporter: bcombee, Unassigned)

Tracking

Fennec 1.1
ARM
Maemo

Details

(Reporter)

Description

9 years ago
When trying to start a local debug build of fennec from today's mobile-browser and 1.9.2 branch

WARNING: NS_ENSURE_TRUE(compMgr) failed: file nsComponentManagerUtils.cpp, line 90
/home/bcombee/src/mozilla-central/memory/jemalloc/jemalloc.c:5826: Failed assertion: "((alignment - 1) & alignment) == 0 && alignment >= sizeof(void *)"
Aborted

Couldn't go very far with this failing immediately.
(Reporter)

Comment 1

9 years ago
BT from device (but without good symbols)

(gdb) bt
#0  0x410524b8 in raise () from /lib/libc.so.6
#1  0x41053adc in abort () from /lib/libc.so.6
#2  0x00036e78 in memalign ()
#3  0x41093b0c in memalign () from /lib/libc.so.6
#4  0x41010e24 in __tls_get_addr () from /lib/ld-linux.so.3
#5  0x43f5ef7c in ?? () from /home/opt/xulrunner-1.9.2b6pre/libxul.so
#6  0x43f5ef7c in ?? () from /home/opt/xulrunner-1.9.2b6pre/libxul.so
(Reporter)

Comment 2

9 years ago
OK, I'm seeing memalign get called from __tls_get_addr with alignment and size both set to 1.  This fails the assert because 1 < sizeof(void *).
(Reporter)

Comment 3

9 years ago
I think the assert is a bit broad here... it seems like it would be better to have the current assert to catch requests for non-powers of two, but then to have code that converts requests for alignment < sizeof(void*) into a request for alignment of sizeof(void *).
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 526152

Updated

8 years ago
Component: Linux/Maemo → General
You need to log in before you can comment on or make changes to this bug.