TB3 does not start because of "Already running[...]" message

RESOLVED DUPLICATE of bug 278860

Status

--
critical
RESOLVED DUPLICATE of bug 278860
9 years ago
8 years ago

People

(Reporter: raf64flo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.5) Gecko/20091109 Ubuntu/9.10 (karmic) Firefox/3.5.5
Build Identifier: http://pj-mirror01.mozilla.org/pub/mozilla.org/thunderbird/releases/3.0/linux-i686/fr/thunderbird-3.0.tar.bz2

I have downloaded 2 times TB3 from Mozilla server, french Linux version, I bunzipped/untar it and launched thunderbird sh script but I always have following error (manually (badly) translated to EN):
"Thunderbird already running but does not answer. For opening a new window you may first stop Thunderbird existing process or reboot you system."
Original french is: 
"Thunderbird est déjà en cours d'exécution mais ne répond pas. Pour ouvrir une nouvelle fenêtre, vous devez d'abord arrêter le processus Thunderbird existant ou redémarrer votre système."

Currently, no TB process is running, I have restarted my computer but the same message occurs.

No .parentlock file exist anywhere in TB profile.

Is this a known problem? Do you may need another informations from my system?

Any help would be greatly appreciated.

Reproducible: Always

Steps to Reproduce:
1. DL TB3 final
2. unpack it
3. run thunderbird sh script
Actual Results:  
A box with error message is shown precising TB3 is already running, but no process is runnig

Expected Results:  
It should start normally.

The problem occurs either a profile already exists or not. Here is my TB2 profiles.ini:
-----------------------------------------------
[General]
StartWithLastProfile=1

[Profile0]
Name=default
IsRelative=1
Path=rlcgxhbi.default
-----------------------------------------------

No .parentlock file exist anywhere in TB profile.

Two 1,86GHz Intel Genuine Intel(R) CPU           T2130  @ 1.86GHz Processors, 1,9GB RAM, 7448,00 Bogomips Total

Some commands:

$ uname -a
Linux laptop 2.6.31-16-generic #52-Ubuntu SMP Thu Dec 3 22:00:22 UTC 2009 i686 GNU/Linux

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 9.10
Release:        9.10
Codename:       karmic
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0
(In reply to comment #0)

> The problem occurs either a profile already exists or not. Here is my TB2
> profiles.ini:
>(snip)
> Name=default
> IsRelative=1
> Path=rlcgxhbi.default

Does directory pointed by IsRelative=1/Path=rlcgxhbi.default exist?
(If profiles.ini==/abc/def/profiles.ini, /abc/def/rlcgxhbi.default)

On MS Win, when profiles.ini==...\abc\def\profile.ini, Tb creates directory of ...\abc\def\Profiles\<string-contains-profilename> and sets IsRelative=1 and Path=Profiles/<string-contains-profilename> in profiles.ini upon profile creation request via profile manager.
How did you create profiles.ini file and the profile.ini entry?

> "Thunderbird already running but does not answer. ... (snip)
> Currently, no TB process is running,
> No .parentlock file exist anywhere in TB profile.

Same problem as Bug 278860? (See also bug 459638)
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Does directory pointed by IsRelative=1/Path=rlcgxhbi.default exist?

Yes, this profiles exists, it is the one used by TB2.

I have tried to remove everything from ~/.mozilla-thunderbird/ but the same error occurs.


> How did you create profiles.ini file and the profile.ini entry?

I'm not sure to remember, but it may was automatic process at first startup of TB.


> Same problem as Bug 278860? (See also bug 459638)

I'll look further this evening with my computer. At office, I don't have had this problem, but I don't know what profile is really used by TB3, can't see differences in my profile folder neither see new folder created.
(Reporter)

Comment 3

9 years ago
For your information, starting using this command make the profile correctly loaded: 
./thunderbird -profile ~/.mozilla-thunderbird/rlcgxhbi.default
So your profile.ini is corrupted.
(Reporter)

Comment 5

9 years ago
You might be wrong if you talk about ~/.mozilla-thunderbird/profile.ini because I have just realised that profile of Thunderbird3 is in ~/.thunderbird directory and not in ~/.mozilla-thunderbird as TB2 profile.ini did.

I currently cannot look at this profile.ini existing in this new directory (I'm at office), but I will take a look this evening to present you its content. Perhaps we will be able to discover if there is any problem related to it.

Comment 6

9 years ago
> No .parentlock file exist anywhere in TB profile.

Note that linux also has a "lock" file, which may be a symbolic link.
If you see it, remove it from the profile and see if TB3 starts then.
(In reply to comment #3)
> For your information, starting using this command make the profile correctly
> loaded: 
> ./thunderbird -profile ~/.mozilla-thunderbird/rlcgxhbi.default

MozillaZine Knowledge Base artcle says: 
> http://kb.mozillazine.org/Profile_folder_-_Thunderbird#Linux_and_Unix
> Linux and Unix
> Profile folders are located here:
>    * ~/.thunderbird/<Profile name>/ 
> However, if you're using a third party build from Debian or Ubuntu,
> those builds store your profile folder here:
>    * ~/.mozilla-thunderbird/<Profile name>. 
Are you checking correct profiles.ini location and correct profile directory location?
(In reply to comment #2)
> I have tried to remove everything from ~/.mozilla-thunderbird/
> but the same error occurs.

If ~/.mozilla-thunderbird/ is profiles.ini location on your Linux, it means "you deleted profiles.ini and all profile directories".
Start Tb3 with -profilemanager(invoke profile manager) and create prof1.
Where is profles.ini which has entry of prof1 created?
Where is directory for prof1 created?
(Reporter)

Comment 9

9 years ago
Ok.

With version 3 of Thunderbird, the user's profile is located in $HOME/.thunderbird/ folder. From the begining I did not look at the good one.

The original profile might be corrupted, I have tested by deleting $HOME/.thunderbird/ folder and starting TB3, it works perfectly !

I think this issue can now be closed.

Thanks for all evrybody! :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You looked into invalid directry, but phenomenon/problem itself is never INVALID at B.M.O. Duping to Bug 278860.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 278860
You need to log in before you can comment on or make changes to this bug.