Make nsArraySH fast-path the case when the object it gets is an nsWrapperCache (dromaeo)

RESOLVED DUPLICATE of bug 590612

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 590612
9 years ago
5 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

In particular, having this work for nodelists would be really nice.
Summary: Make nsArraySH fast-path the case when the object it gets is an nsWrapperCache → Make nsArraySH fast-path the case when the object it gets is an nsWrapperCache (dromaeo)
Peter, did the patch I reviewed earlier today basically do this?  Seems like it did....
Right, a combination of bug 564266 and bug 590612 fixes this I think.
Blocks: 935296
nsArraySH shouldn't be involved here anymore.
No longer blocks: 935296
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 590612
You need to log in before you can comment on or make changes to this bug.