startup can hang with dns timeouts in nsProfileLock

RESOLVED DUPLICATE of bug 433665

Status

Core Graveyard
Profile: BackEnd
RESOLVED DUPLICATE of bug 433665
9 years ago
2 years ago

People

(Reporter: wolfiR, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
There are cases where the resolver library cannot find an IP for a name. This would cause hanging of startup until the DNS timeout has been reached (60 seconds usually).

http://mxr.mozilla.org/mozilla-central/source/profile/dirserviceprovider/src/nsProfileLock.cpp#338

PR_GetHostByName() blocks during the timeout.

After all that seems to be pretty old code which should be revisited.
I'm not sure if the IP address is the right choice at all.
So I see two possible solutions:
- don't use an ip address but probably just the hostname
- get an ip address without asking DNS
(Reporter)

Comment 1

7 years ago
wow, I have to dupe my own two bugs ;-)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433665
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.