Wrong or missing keyboard shortcuts for Hide Thunderbird and Hide Other

RESOLVED FIXED

Status

Mozilla Localizations
it / Italian
--
major
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: Eugenio MORASSI, Assigned: Mozilla Localizers (Italian))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; it; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; it; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

In Thunderbird 2.x keyboard shortcuts for

- Hide Thunderbird
- Hide Other

were following tha AHIG, and were mapped to

- Hide Thunderbird -> [CMD]+[H]
- Hide Other -> [CMD]+[OPT]+[H]

In Thunderbird 3, the first one has NO keyb shortcut associated, the second one is wrong and is associated with [CMD]+[OPT]+[S].

This causes usability problems.
Sincerely I see no reason (nor advantges) to bother users that way.

Reproducible: Always
Assignee: nobody → l10n-it
Component: OS Integration → it / Italian
Product: Thunderbird → Mozilla Localizations
QA Contact: os-integration → prometeo.bugs
I can confirm the problem: both those commandkeys were localized (and they shouldn't be), so we need to fix it for Thunderbird 3.0.1. 

http://mxr.mozilla.org/l10n-mozilla1.9.2/source/it/mail/chrome/messenger/messenger.dtd#679

Already contacted the owner of the mail module to commit a fix.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 533991
A fix has already been committed to Mercurial
http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/it/rev/9bd8d9924637

In the next days we'll ask to use an updated revision (containing also this fix) for Thunderbird 3.0.1.
Summary: Wrong or missing Keybord shotcuts for Hide Thunderbird and Hide Other → Wrong or missing keyboard shortcuts for Hide Thunderbird and Hide Other
(Reporter)

Comment 4

9 years ago
If it's a localization problem, please add to the list the

Incolla come citazione (1) -> [CMD]+[SHIFT]+[O]

that should be 

[CMD]+[SHIFT]+[V]

(1) I think the English version is "Paste as quotation" or something similar.
(In reply to comment #4)
> If it's a localization problem, please add to the list the
> 
> Incolla come citazione (1) -> [CMD]+[SHIFT]+[O]
> > that should be > 
> [CMD]+[SHIFT]+[V]
> 

That's not a translation problem (the same combination is used in en-US)
http://mxr.mozilla.org/comm-central/source/editor/ui/locales/en-US/chrome/composer/editorOverlay.dtd#101

CMD+SHIFT+V it's already in use for "Paste Without Formatting"

Comment 6

7 years ago
Seems like this is fixed, resolving. Feel free to reopen, or file a new bug on the second issue.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.