PDF Support Problem: Undocumented Feature of NS API

VERIFIED DUPLICATE of bug 53372

Status

()

Core
Plug-ins
P3
critical
VERIFIED DUPLICATE of bug 53372
18 years ago
8 years ago

People

(Reporter: lmcquarr, Assigned: av (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This bug is related to 53363.  Please read that first.

There is an undocumented feature of the old NS API that Acrobat relies on
in order to make byte range requests work.  I am pretty sure I wrote
a bug about this early this year, but my hard disk crashed so
I can't easily produce the bug number.

Basically, the behavior of Nav 4.X and earlier (and now Mac IE 5) is that
when Nav encounters a PDF file, it starts an initial connection and pours
the file into Acrobat (NPP_Write).  It keeps that initial connection
open and pouring **until* the first NPN_RequestRead.   At that point,
it kills the initial connection.  

NPN_RequestRead currently is broken (53363), so I am not sure if this
undocumented feature is currently supported or not.  I suspect not.
And like the other aspects of byte range requests that I discuss
in bugs 53363 and 53344, this feature is absolutely necessary
to make mozilla a useable platform for Acrobat.

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 53372 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
v
Status: RESOLVED → VERIFIED
Duplicate of this bug: 568160

Comment 4

8 years ago
My apologies to mati and others who have been trying to get through to me: As I said, I'm not *always* able to type.

There is also a problem in the middle I am trying to deal with. Instead of throwing a 404 at you if you botch input of an address (misspellings, selection of wrong domain) FIOS goes to Yahoo and initiates an infotheft>yahoo yahoo search, and integrates the answer into its own page.

lmcqarr's statement indicates a dangerous hole in the system:
"when Nav encounters a PDF file, it starts an initial connection and pours
the file into Acrobat (NPP_Write).  It keeps that initial connection
open and pouring **until* the first NPN_RequestRead." the question becomes 'can a malevolent script be packed into that first pdf file it hits'

I'll try to do a 'slash and burn' remove and install today.
Even my properly-formed SMPT accounts will not allow me to send mail out - still.

Comment 5

8 years ago
My apologies to mati and others who have been trying to get through to me: As I said, I'm not *always* able to type.

There is also a problem in the middle I am trying to deal with. Instead of throwing a 404 at you if you botch input of an address (misspellings, selection of wrong domain) FIOS goes to Yahoo and initiates an infotheft>yahoo yahoo search, and integrates the answer into its own page.

lmcqarr's statement indicates a dangerous hole in the system:
"when Nav encounters a PDF file, it starts an initial connection and pours
the file into Acrobat (NPP_Write).  It keeps that initial connection
open and pouring **until* the first NPN_RequestRead." the question becomes 'can a malevolent script be packed into that first pdf file it hits'

I'll try to do a 'slash and burn' remove and install today.
Even my properly-formed SMPT accounts will not allow me to send mail out - still.
You need to log in before you can comment on or make changes to this bug.