Incorrect caret positioning after bulleted list

RESOLVED DUPLICATE of bug 483583

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 483583
8 years ago
8 years ago

People

(Reporter: Gyorgy Szilagyi, Unassigned)

Tracking

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: 20091130201643

When the caret it positioned at the end of the line after the bulleted list, it will jump to the previous line when I start typing.

Reproducible: Always

Steps to Reproduce:
1. Write 5 lines of text (one word in each line is enough)
2. Select lines 2 to 4 and turn them into a bulleted list
3. Place the caret at the end of line 4 (last bullet point)
4. Hit enter twice (so that an empty line is created between lines 4 and 5
5. Place the caret at the end of line 5
6. Start typing. You'll see the caret jumping one line up (to the empty line between lines 4 and 5).
Actual Results:  
The caret jumps one line up.

Expected Results:  
The caret should not move.

It might be important that in Tools/Options/Composition/General/HTML I have defined a style different from the default (verdana/small).
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
Whiteboard: dupme

Comment 1

8 years ago
4. Hit enter twice (so that an empty line is created between lines 4 and 5

Instead of hitting enter twice, hit enter once, then un-bullet (hit the bullet icon)
That should place the caret where you want.

The HTML editor is full of such quirks, it's old code, and no imminent re-write is in sight.

I don't know of a dup of this, but there probably is one.

Comment 2

8 years ago
Reporter, I can duplicate the problem here, so confirming as "new"

Please search bugzilla with the following search to check for a possible dup

https://bugzilla.mozilla.org/buglist.cgi?short_desc=caret;classification=Client%20Software;query_format=advanced;short_desc_type=allwordssubstr;component=Message%20Compose%20Window;product=Thunderbird
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think that this issue is the same of bug #483583.

Feel free to reopen it if I'm wrong.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 483583
You need to log in before you can comment on or make changes to this bug.