Bad handling of HTML title page when using "Send a link" in the email subject

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Manuel FLURY, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

When using menu "Send a link" from an HTML page containing in the title non ASCII characters, the generated subhect email contains wrongly converted characters.

For instance on this page : http://www.google.com/search?hl=en&q=%E9%E8%E0%E7

The generated email subject line is : éèàç - Google Search

Reproducible: Always

Steps to Reproduce:
1. Go here http://www.google.com/search?hl=en&q=%E9%E8%E0%E7
2. Menu File then Send a link to this page
3. Check the subject line of the email
Actual Results:  
éèà ç - Google Search

Expected Results:  
éèàç - Google Search

Verified using Outlook 2003 SP3 and Mozilla Thunderbird with Windows or Linux

A similar bug exists already here : https://bugzilla.mozilla.org/show_bug.cgi?id=227268

but seems to be for windows 2000 for old version of mozilla and abandonned.
(Reporter)

Comment 1

8 years ago
Retried using FF 3.5.5 under Linux

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091107
Firefox/3.5.5 (Swiftfox) (.NET CLR 3.5.30729)

and Thunderbird version 2.0.0.23 (20090817)

and it seems to work.

That would mean the bug stands in the email client I guess (?).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 2

8 years ago
http://www.idg.se/2.1085/1.285190/ny-databas-raddningen-for-webben

Same result with Outlook 2003 and it works with IE 7 so it really looks like this is the Firefox browser somehow.
You need to log in before you can comment on or make changes to this bug.