Closed Bug 533709 Opened 11 years ago Closed 6 years ago

Soffront Ticket web page left hand side bar has disappeared after upgrade

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: boyce.wong, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.16) Gecko/2009120123 Camino/2.0.1 (like Firefox/3.0.16)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.16) Gecko/2009120123 Camino/2.0.1 (like Firefox/3.0.16)

Bofore upgrade to 2.0, I can use Camino to access my company's ticket web page properly with left hand side bar. However, after upgrade, it disappeared.

By using Netscape, I can see the side bar as attached.

Reproducible: Always

Steps to Reproduce:
1.login
2.
3.



I want to attach the web page files and screen capture. However, I cannot provide any attachment URL. How should I upload the attachments to this bug report?
Well, I'm not shocked Netscape works, since there's Netscape-specific browser sniffing all over the HTML file you uploaded.

Does Firefox 3.0 (or 3.5) work?

Can you provide a URL where this happens?
It worked before for Firefox 2.0 in WinXP. But same behavior, after upgrade to Firefox 3.0 or Firefox 3.5 in WinXP, it has the same behavior as Camino 2.0 right now.

Sorry that it is my company internal web. It requires login to access the page. So, I have uploaded the asp and screen capture in this bug report.

(In reply to comment #2)
> Well, I'm not shocked Netscape works, since there's Netscape-specific browser
> sniffing all over the HTML file you uploaded.
> 
> Does Firefox 3.0 (or 3.5) work?
> 
> Can you provide a URL where this happens?
May I know what exactly the meaning "there's Netscape-specific browser sniffing all over the HTML file you uploaded" is?

(In reply to comment #2)
> Well, I'm not shocked Netscape works, since there's Netscape-specific browser
> sniffing all over the HTML file you uploaded.
> 
> Does Firefox 3.0 (or 3.5) work?
> 
> Can you provide a URL where this happens?
Since this happens in both Firefox 3 and 3.5, this really shouldn't be a Camino bug. It screams "Tech Evangelism" with that busted sniffing, especially since it sounds like IE is the only "modern" browser that works with it.

I realise this is an internal Web app, but is it something that your company makes themselves, or is it just a single installation of some other company's software? That makes a difference in who we need to talk to to get this fixed.

I'm gonna kick this over to TE for now and confirm it, since it's pretty obvious they're doing something funky.
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
OS: Mac OS X → All
Product: Camino → Tech Evangelism
QA Contact: general → english-us
Hardware: x86 → All
(In reply to comment #4)
> May I know what exactly the meaning "there's Netscape-specific browser sniffing
> all over the HTML file you uploaded" is?

Search the .html file for the word "netscape" and you'll see what I mean. The Javascript in that file is looking specifically for browsers called "Netscape", which partially explains the problems.
I poked around a lot in the files you attached and was never able to figure out what was wrong (HTML Complete didn't save a number of files that the HTML and JS referred to, which hampered my investigation, and there are some JS calls in there that require same-origin to work, which also made working with a local copy ineffective).

It's possible there are two issues here, one being browser-sniffing, which Chris has already mentioned, and another being changes or removal of old DOM behavior in Gecko 1.9 (used by Camino 2 and Firefox 3). I noticed some warnings about this in ChimericalConsole in Camino 2 but they were not in Camino 1.6.x (Gecko 1.8.1, like Firefox 2).

If it's *only* browser-sniffing that's the problem, you should be able to use something like the User Agent preference pane (http://pimpmycamino.com/parts/user-agent) to spoof your user-agent string as Netscape and have the menu appear (there are similar extensions for Firefox 3.x). Note you should only spoof your user-agent when absolutely required and should reset it when done with the site, since spoofing the wrong user-agent will silently break other sites ;)

If spoofing you user-agent "fixes" the menu, then the problem is certainly an evangelism issue that should be forwarded to the developers of the Soffront Ticket app.  If that doesn't fix it, it could still be an evangelism issue, since it appears the ticket system is using old/removed DOM methods.
incomplete no URI to test.
And RIP Camino.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.