PDF Support Problem: Undocumented Feature of NS API

VERIFIED DUPLICATE of bug 53372

Status

()

P3
critical
VERIFIED DUPLICATE of bug 53372
18 years ago
18 years ago

People

(Reporter: lmcquarr, Assigned: serhunt)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This bug is related to 53363.  Please read that first.

There is an undocumented feature of the old NS API that Acrobat relies on
in order to make byte range requests work.  I am pretty sure I wrote
a bug about this early this year, but my hard disk crashed so
I can't easily produce the bug number.

Basically, the behavior of Nav 4.X and earlier (and now Mac IE 5) is that
when Nav encounters a PDF file, it starts an initial connection and pours
the file into Acrobat (NPP_Write).  It keeps that initial connection
open and pouring **until* the first NPN_RequestRead.   At that point,
it kills the initial connection.  

NPN_RequestRead currently is broken (53363), so I am not sure if this
undocumented feature is currently supported or not.  I suspect not.
And like the other aspects of byte range requests that I discuss
in bugs 53363 and 53344, this feature is absolutely necessary
to make mozilla a useable platform for Acrobat.
(Reporter)

Comment 1

18 years ago
Sorry -- this is a dup of 53372 (I got impatient with your server
and committed the bug several times).

Comment 2

18 years ago

*** This bug has been marked as a duplicate of 53372 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.