When composing mail, pasting a URL or e-mail address into the message sends the entry point back to the beginning of the message.

NEW
Unassigned

Status

SeaMonkey
MailNews: Composition
9 years ago
7 years ago

People

(Reporter: Michael Graubart, Unassigned)

Tracking

SeaMonkey 2.0 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0

If one types a new e-mail message which is to include a URL or an e-mail address within the message; and one copies and pastes the URL or address into the body of the message, the text entry-point jumps back to the very beginning of the message, which can be very annoying if one is touch-typing and does not notice that the entry point is no longer at the right point in the message.

Reproducible: Always

Steps to Reproduce:
1. Copy a URL or an e-mail address.
2. Start composing a new message.
3. Paste the copied URL or address into the message.
Actual Results:  
The text entry-point jumps back to the very beginning of the typed message.

Expected Results:  
The text entry-point should remain after the pasted URL or e-mail address.

Mac G4 (PPC), OS X 10.4.11. CopyPaste 2.7.5 used for copying and pasting. (NB: CopyPaste Pro can be erratic about what is pasted, but v. 2.7.5 is stable and reliable.)

Comment 1

9 years ago
Does this happen only for HTML-formatted mails? If so, please create a sample mail, save it as .eml file and attach it to this report.

Does this happen when you copy the URL or email address from a plain text editor?
Component: General → MailNews: Composition
QA Contact: general → mailnews-composition
Version: unspecified → SeaMonkey 2.0 Branch
(Reporter)

Comment 2

9 years ago
Created attachment 417380 [details]
New e-mail with URL copied from address bar
(Reporter)

Comment 3

9 years ago
Created attachment 417381 [details]
New e-mail with a URL copied from within another e-mail
(Reporter)

Comment 4

9 years ago
Created attachment 417382 [details]
New plain-text e-mail with a URL copied from another e-mail

Comment 5

9 years ago
Attachment 417382 [details] isn't a plain-text mail.

Composer and Editor with HTML-Mails have problems with some kind of clipboard content. See bug 527905.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
OS: Mac OS X → All
Hardware: PowerPC → All
Resolution: --- → DUPLICATE
Version: SeaMonkey 2.0 Branch → Trunk
Duplicate of bug: 527905

Updated

7 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Comment 6

7 years ago
Tested against current trunk (SM2.6) and cannot reproduce in message compose or web composer.
Could you test against SM2.3 and see the issue is still there?
Status: REOPENED → NEW

Comment 7

7 years ago
Could not reproduce in SM 2.3 under Windows. Bug was initially reported on PowerPC. What now?

Comment 8

7 years ago
Hopefully the original reporter or someone else on OSX could test it against SM2.3
(Reporter)

Comment 9

7 years ago
I'm afraid someone else will have to test this on SM 2.3. My computer is a G4 (PPC) with OS 10.4.11, and SM 2.3 will not run on it. 

Michael Graubart (original reporter).

Comment 10

7 years ago
Back to 2.0 Branch.
Version: Trunk → SeaMonkey 2.0 Branch
You need to log in before you can comment on or make changes to this bug.