Archive should save the folder structure as well

RESOLVED DUPLICATE of bug 522761

Status

--
enhancement
RESOLVED DUPLICATE of bug 522761
9 years ago
9 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

Now, when you click Archive, the message is moved to a folder named "Year".

However, in order to make this feature really useful it would be great that beside moving it to a "Year" folder, Thunderbird move it to a "Year" -> "Original folder" folder.

Keeping folder structure in the Archive like Lotus Notes already does would make browsing it much more easier, specially for users who use filters and have developed an important folder assisted logic to manage their email.

Reproducible: Always
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

9 years ago
Strongly agree. For those who file their email into meaningful folders, having that structure disappear if you archive them is Bad News. This is especially important for enterprise use.
I'm just trying to clarify this a bit.  If you were to archive a mail in the Mozilla folder according to the following structure.

[-]-Clients
 \--Mozilla

You would expect that it then is archived under the Archives/$YEAR folder like the example below.

[-]-Archives
 \[-]--2009
   \[-]-Clients
     \--Mozilla
OS: Windows Vista → All
Hardware: x86 → All
Version: unspecified → Trunk

Comment 3

9 years ago
Hello,

I would like to confirm your example and also to extend the time period.
Today it is possible to have year and month. Would it be possible to have also
Quarter and Semester and also keep the hierarchy as you propose in your example.

Would it be possible to do it via an extension because I have seen that the code is in the mailWindowOverlay.js and is it possible by extension to override or extend those functions.

I am ready to try even if I have not made any js since 5 years.

Kind Regards
Hi Christophe, this is possible to do as an extension and is exactly what we had hoped for.  There are as many different types of organizing archives as there are people using Thunderbird so we'll need extensions to provide most of the different ways.

Comment 5

9 years ago
Bryan, yes, #2 is exactly what I would want to see (possibly with the month granularity option, but that would just be a wish, the other is a must. I've got 300 users here, some with hundreds of folders (been using moz/TB for 7 years in our institution) and whilst I like the archive folder (it can be on cheaper, slower storage with less frequent backups - we've already implemented it for people to manually archive) it's useless without keeping their folder structure.

So unless we get this, or get a way to disable/hide all mention of the archive feature, we're stuck on TB2.

Comment 6

9 years ago
Hello Bryan,

I have an extension which is working but I have a XUL issue. Please do not hesitate to send a email to test and give feedbacks.
Please bear that I have not done any dev for more than 5 years.

Kind Regards
Hi Christophe,  I sent you some mail about the extension.  If you have a URL for it you could post it here and I could take a look.  If you don't have it up anywhere yet you could post it up on any of the free source control / code hosting services.

git: http://github.com/
mercurial: http://bitbucket.org/

Comment 8

9 years ago
This is something that we would really need here. I'd help testing...

Comment 9

9 years ago
Isn't this a duplicate of bug #522761?
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 522761
You need to log in before you can comment on or make changes to this bug.