Message filters msgFilterRules.dat disappeared after installing new Thunderbird 3

RESOLVED WORKSFORME

Status

MailNews Core
Filters
--
critical
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Ondrej Sluciak, Unassigned)

Tracking

({dataloss})

1.9.2 Branch
x86
Windows XP
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0

I installed today's final version of thunderbird. Everything went fine, except the message filters which disappeared. I had to write them once more, and even then,  if I run them on selected folder (and on selected message from which I created the filter rule), the filter doesn't work. It works fine for all new incoming messages, but not on the already received. 

Reproducible: Always

Comment 1

8 years ago
Ondrej, is all working OK now?
Severity: normal → critical
Component: Migration → General
Keywords: dataloss
QA Contact: migration → general
(Reporter)

Comment 2

8 years ago
Well, I didn't try to install it once more. After updating from TB2 I had to write all the filters again, and now they work. But I don't know if the problem is fixed in the latest version. Honestly, I don't want to reinstall something that works...also since it seems that I was the only one who reported this, I guess the problem was not so severe...

Comment 3

6 years ago
(In reply to Ondrej Sluciak from comment #2)
> Well, I didn't try to install it once more. After updating from TB2 I had to
> write all the filters again, and now they work. But I don't know if the
> problem is fixed in the latest version. Honestly, I don't want to reinstall
> something that works...
yeah. that's completely understandable. 


> also since it seems that I was the only one who
> reported this, I guess the problem was not so severe...
might be a duplicate. But I'm not sure, and very hard to tell without very precise steps. Let's see if anyone else knows of such a bug report
Whiteboard: [dupeme?]

Comment 4

6 years ago
Ondrej, have you ever seen this again?
(Reporter)

Comment 5

6 years ago
No. Although since then I have always only upgraded thunderbird and never reinstalled.

Comment 6

6 years ago
thanks Ondrej

no one else has stepped forward. So I guess we'll call this WFM.

However, there are a couple reports of lost msgFilterRules.dat on version 3 or newer:
- my bug 713253 
- the reporter of bp-7a462531-f732-415e-942d-665e12111225
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Resolution: --- → WORKSFORME
Summary: Message filters disappeared after installing new Thunderbird 3 → Message filters msgFilterRules.dat disappeared after installing new Thunderbird 3
Whiteboard: [dupeme?]
Version: unspecified → 1.9.2 Branch
You need to log in before you can comment on or make changes to this bug.