A saved email has no suffix

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: tom, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

I need to save emails for an external workflow.
Using Thunderbird 2 I got always a suffix ".eml".
Using Thunderbird 3 there is no suffix anymore and I need to enter it manually.

Please add the suffix for the filename which makes it easier for the user.

The suffix is e.g. needed for Mac OS X "quicklook" to open a view for the file in Finder.

Reproducible: Always

Steps to Reproduce:
1. Save an email and notice that the name has no longer any suffix.

Actual Results:  
No Suffix on the saved email

Expected Results:  
An ".eml" Suffix on the saved file

# sw_vers 
ProductName:	Mac OS X
ProductVersion:	10.6.2
BuildVersion:	10C540
This works for me on 10.5.

can you try in -safe-mode (http://kb.mozillazine.org/Safe_mode) ?
(Reporter)

Comment 2

9 years ago
> can you try in -safe-mode

I did and I noticed that my error description was incomplete (sorry for this). The behavior is the same for safe-mode or "normal" as described below:

Create a file "draft.eml" your Desktop.
Now go to Thunderbird and save an email.
In the save-dialog navigate to the Desktop and click at "draft.eml".
Now you see that the name in the save dialog is only "draft" and so the mail is saved without a suffix.
The real problem is that the filename from the clicked file is shown without a suffix.
Why would I need to create the file I want to save, before saving it ?

If I select an email and save it it will end with .eml. I don't understand your workflow.
(Reporter)

Comment 4

9 years ago
I need to save a mail to a specific folder where I overwrite an existing template.
This updated file is used in the further workflow.

I use this for a long time now without any problems in Thunderbird 2 and it is broken now for me.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 5

9 years ago
can't reproduce this in windows. In windows there are settings to hide extensions but I don't know if that has anything to do with this anyway.

rt click message in TB, saveas- name has form of <subject>.eml. 
click on existing file <somefile>.eml 
save. 

Not sure where your steps to repro fails since I have no problem.
(Reporter)

Comment 6

3 years ago
I cannot reproduce this issue anymore using TB 38.2.0
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.