FX crashed but there was no gdb indication of same(?)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: dennisgdaniels, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15 Version/10.10
Build Identifier: [user@localhost ~]$ rpm -qa firefox firefox-3.5.5-1.fc12.i686 

browsing. multiple tabs opened. Fx stopped working.

Reproducible: Always

Steps to Reproduce:
1.open Fx 
2.open tabs/ browse
3.Fx froze ( don't recall doing anything other than browsing/ sidewiki entries/ reading wikipedia)
Actual Results:  
Fx froze
(Reporter)

Comment 1

9 years ago
Created attachment 416882 [details]
screengrab of firefox freezing

I was watching gdb output and saw no indication of Fx about to barf.
(Reporter)

Comment 2

9 years ago
Created attachment 416883 [details]
gdb output

Need the gdb command that will spit out the errors to a text file on the desktop.

Comment 3

9 years ago
Looks like you might be running Python under gdb rather than Firefox?  Make sure you run firefox-bin under gdb (or use "firefox -g -d gdb").  https://developer.mozilla.org/En/Debugging_Mozilla_on_Linux_FAQ

Or you could try installing the mozilla.com version of Firefox 3.5.5 and use the built-in crash reporter (which is absent in Fedora versions).  https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

Comment 4

9 years ago
jesse: no, it's a gecko, but the distro includes pyxpcom support

Comment 5

9 years ago
Did Firefox exit on its own (crash) or did it just hang?  If it hangs, I think you have to Ctrl+C it in gdb to get a stack trace.  You might also have to install debuginfo stuff (https://developer.mozilla.org/En/Debugging_Mozilla_on_Linux_FAQ explains how).

timeless adds: one could use xtree (?) to see if the xwindows exist or went somewhere "amusing"
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
(Reporter)

Comment 7

8 years ago
The caveat about safe mode makes renders this a closed bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.