Fx doesn't load pages, hangs. Same pages work fine on Opera 10

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: dennisgdaniels, Unassigned)

Tracking

({hang, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-15])

Attachments

(7 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15 Version/10.10
Build Identifier: 3.6b4

Fx doesn't load pages, crashes. Same pages work fine on Opera 10
Hoped to solve 3.5.5 problems by upgrading. No joy. Fx still loads extra slow. Opera is fine.

Reproducible: Always




see back trace and screen grab of freeze. GDB doesn't produce any output re: slow pages or Fx in train to freeze.
(Reporter)

Comment 1

9 years ago
Created attachment 416888 [details]
fx beta backtrace

lots of question marks in output :(
(Reporter)

Comment 2

9 years ago
Created attachment 416889 [details]
screengrab

fx freezing
(Reporter)

Comment 3

9 years ago
Happened again immediately
(Reporter)

Comment 4

9 years ago
Created attachment 416891 [details]
backtrace

backtrace
(Reporter)

Comment 5

9 years ago
Created attachment 416892 [details]
screengrab

screengrab
(Reporter)

Comment 6

9 years ago
Created attachment 416893 [details]
dmesg

Updated

9 years ago
Keywords: hang, stackwanted
Summary: Fx doesn't load pages, crashes. Same pages work fine on Opera 10 → Fx doesn't load pages, hangs. Same pages work fine on Opera 10
(Reporter)

Comment 7

9 years ago
Created attachment 416907 [details]
firefox 3.5.5 freezes up on me on a daily basis

Trying to show how Fx always borks on Blogger.com but never even really got there... Fx borked before that.
(Reporter)

Comment 8

9 years ago
Here are some of the videos I've made of the problems:
http://sites.google.com/site/lifewithfedora12/home/all-animated-gif

Something has changed in the ogg theora playback as all of my screencasts made with recordmydesktop don't play correctly anymore otherwise I'd post those too.
(Reporter)

Comment 9

9 years ago
(In reply to comment #7)
> Created an attachment (id=416907) [details]
> firefox 3.5.5 freezes up on me on a daily basis
> 
> Trying to show how Fx always borks on Blogger.com but never even really got
> there... Fx borked before that.

http://sites.google.com/site/lifewithfedora12/home/all-animated-gif/fx_frozen_on_blogger.gif?attredirects=0
(Reporter)

Comment 10

9 years ago
Google sites are very much affected ... What is bad is that I'm getting DNS errors but only on my Fedora machines, not my vista or XP machines that are on the same network.
http://sites.google.com/site/lifewithfedora12/home/all-animated-gif/firefoxhasalotoftroublewithgooglebasedsitesandservices.gif?attredirects=0
(Reporter)

Comment 11

9 years ago
I ran these commands looking for some clue as to why Fx runs times out so quickly after contacting a web page. Opera works just fine on the same machine.

[user@localhost ~]$ netstat -nr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
192.168.122.0   0.0.0.0         255.255.255.0   U         0 0          0 virbr0
0.0.0.0         192.168.0.1     0.0.0.0         UG        0 0          0 eth0
[user@localhost ~]$ /sbin/ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:16:D4:EF:20:AA  
          inet addr:192.168.0.103  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23466 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21332 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:19097057 (18.2 MiB)  TX bytes:3668955 (3.4 MiB)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:29451 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29451 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2697404 (2.5 MiB)  TX bytes:2697404 (2.5 MiB)

virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:4142 (4.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:1B:77:34:8F:1F  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wmaster0  Link encap:UNSPEC  HWaddr 00-1B-77-34-8F-1F-71-A2-00-00-00-00-00-00-00-00  
          [NO FLAGS]  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

[user@localhost ~]$ cat /etc/re
readahead.conf  redhat-lsb/     redhat-release  resolv.conf     
[user@localhost ~]$ cat /etc/resolv.conf 
# Generated by NetworkManager
nameserver 192.168.0.1
[user@localhost ~]$ cat /etc/hosts
# hostname localhost.localdomain added to /etc/hosts by anaconda
127.0.0.1		localhost.localdomain localhost
::1		localhost6.localdomain6 localhost6 localhost.localdomain
(Reporter)

Comment 12

9 years ago
TCP timing out/ low socket buffer errors

[user@localhost ~]$ netstat -t -s
IcmpMsg:
    InType3: 8
    OutType3: 1
Tcp:
    913 active connections openings
    2 passive connection openings
    4 failed connection attempts
    186 connection resets received
    11 connections established
    50658 segments received
    48364 segments send out
    2301 segments retransmited
    0 bad segments received.
    37 resets sent
UdpLite:
TcpExt:
    2 packets pruned from receive queue because of socket buffer overrun
    339 TCP sockets finished time wait in fast timer
    1 time wait sockets recycled by time stamp
    889 delayed acks sent
    Quick ack mode was activated 902 times
    1128 packets directly queued to recvmsg prequeue.
    100 packets directly received from prequeue
    29360 packets header predicted
    2713 acknowledgments not containing data received
    17473 predicted acknowledgments
    20 congestion windows recovered after partial ack
    0 TCP data loss events
    1 timeouts in loss state
    17 retransmits in slow start
    280 other TCP timeouts
    124 packets collapsed in receive queue due to low socket buffer
    895 DSACKs sent for old packets
    3 DSACKs received
    5 connections reset due to unexpected data
    4 connections reset due to early user close
    56 connections aborted due to timeout
    TCPDSACKIgnoredOld: 1
    TCPDSACKIgnoredNoUndo: 2
    TCPSackShiftFallback: 26
IpExt:
    InMcastPkts: 1037
    OutMcastPkts: 44
    InBcastPkts: 761
    InOctets: 21952123
    OutOctets: 6078825
    InMcastOctets: 167653
    OutMcastOctets: 7668
    InBcastOctets: 104650
(Reporter)

Comment 13

9 years ago
Digging around in iptraf and 192.168.0.1 (dlink dir300) I see that my dlink router is handling all of my sessions as UDP... 
IP Address	TCP Session	UDP Session	 
192.168.0.102	      7	         30	
192.168.0.105	      48	13	
192.168.0.103	        33	0<<<<<<<<<<<<<

I'm on eth0. What is more curious is that when I go to the session history: 
TCP	192.168.0.103	53903	192.168.0.1	80
TCP	192.168.0.103	35717	89.108.94.66	80<<<nginx! is running?!
TCP	192.168.0.103	53613	192.168.0.1	53
TCP	192.168.0.103	43147	80.239.242.252	80
TCP	192.168.0.103	48258	192.168.0.1	53
TCP	192.168.0.103	48266	192.168.0.1	53
TCP	192.168.0.103	55210	80.93.53.88	80 <<.ru tv
TCP	192.168.0.103	35714	89.108.94.66	80<<<nginx! is running?!
TCP	192.168.0.103	48292	80.239.242.252	80<<nothin?
TCP	192.168.0.103	53918	192.168.0.1	80
TCP	192.168.0.103	34904	192.168.0.1	53
TCP	192.168.0.103	35712	89.108.94.66	80<<<nginx! is running?!
***

And a lot of my requests are going to my router 192.168.0.1 I compared that traffic to traffic on the other machines and found very different numbers.

So, nginx is handling my web requests maybe?
(Reporter)

Comment 14

9 years ago
Created attachment 417468 [details]
fx hangs daily and often
(Reporter)

Updated

9 years ago
Severity: normal → major
(Reporter)

Comment 15

9 years ago
The fix appears to be:

Putting the correct nameserver in system-config-network


[root@localhost ~]# system-config-network
[root@localhost ~]# cat /etc/resolv.conf
# Generated by NetworkManager
search 192.168.160.190
nameserver 192.168.160.190
nameserver 192.168.160.188
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-15]
(Reporter)

Comment 17

8 years ago
Probably extension problems causing the above. Moving to chrome anyway. It's faster.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.