Spell checker does not check spelling prior to a correction

RESOLVED WORKSFORME

Status

()

Firefox
General
--
minor
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: pkgingo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

In a text box, you can make multiple spelling mistakes. If the user makes a correction near the end of the text box, all prior spelling mistakes that were marked become unmarked. All text that is incorrect after the spelling correction is still correctly marked.

Reproducible: Always

Steps to Reproduce:
1. Type three misspelled words in a text box.
2. Right click the middle word and opt to correct it with a suggestion from Firefox.
3. First misspelled word will be marked as correctly spelled. Last misspelled word will remain marked as incorrectly spelled.
Actual Results:  
First misspelled word will be marked incorrectly as spelled right. Last misspelled word will remain correctly marked as incorrectly spelled.

Expected Results:  
First and last misspelled words should be marked as incorrectly spelled.

The problem can be worked around by scrolling to the beginning of the text box and correcting spelling from start to finish instead of arbitrarily.

Comment 1

8 years ago
I wasn't able to reproduce. Does this happen on a specific site? Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 2

8 years ago
Tim,

Thanks for looking into this. I tried your suggestion and it works, through disabling of all extensions and re-enabling one by one I found the problem is with firegpg. Thanks for your help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 3

8 years ago
I don't have the problem with FireGPG installed, I don't think it's related.
You need to log in before you can comment on or make changes to this bug.