TB 3.0 Final hangs with 100 % CPU at restart/startup after installing/deinstalling Add-ons (enigmail)

RESOLVED INVALID

Status

Thunderbird
General
--
critical
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: Rotis, Unassigned)

Tracking

({hang, perf})

x86
Mac OS X
hang, perf

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [add-on: enigmail])

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

TB hangs every time with 100 % CPU at restart after installing/deinstalling Add-ons. I always have to kill the hanging process. This bug seems to be similar to Bug 508263.

My machine: MacBook 2.26 GHz Intel 2 Core Duo on MacOSX 10.6.2

Reproducible: Always

Steps to Reproduce:
1. Install Add-on and restart TB 3 Final.
2. CPU goes 100 %
3. Process hangs
4. CPU temp goes up
5. Fans start
(Reporter)

Comment 1

8 years ago
Created attachment 416903 [details]
Protocol of a hang from Activity Monitor
Keywords: hang, perf
(Reporter)

Comment 2

8 years ago
After a little testing in safe mode Thunderbird doesn't crash. Probably a problem with some add-ons or the Add-on Manager? Stylish 1.0.7 sometimes (not always) draws its icon in the buttons.

Adblock Plus 1.1.1
Adblock Plus: Element Hiding Helper 1.0.6
After Delete 1.1
Allow HTML temp - Pinstripe Theme 1.0.3 [DISABLED]
Allow HTML Temp 2.0.1 [DISABLED]
Deutsches Wörterbuch 1.0.2
Enigmail 1.0
ImportExportTools (Mboximport enhanced) 2.3.1
keyconfig 20050313.1 [DISABLED]
MagicSLR - Pinstripe Theme 1.2.2 [DISABLED]
MagicSLR 2.0 [DISABLED]
Menu Editor 1.2.3.3 [DISABLED]
Mnenhy 0.7.6.666 [DISABLED]
Nightly Tester Tools 2.0.3
Quickfile 0.17.0.0011 [DISABLED]
Quicktext 0.9.10.0
Quote Colors 0.3
Remove Duplicate Messages (Alternate) 0.3.2
Stylish 1.0.7
(Reporter)

Comment 3

8 years ago
Created attachment 416904 [details]
Bug of Stylish or Add-on Manager? Source of hangs?
So you issue could come from any of these. There's a known issue in enigmail - so try disabling enigmail. 

The issue is clearly in an extension not a TB issue so i'm goingt to close this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Updated

8 years ago
Summary: TB 3.0 Final hangs with 100 % CPU at restart after installing/deinstalling Add-ons → TB 3.0 Final hangs with 100 % CPU at restart after installing/deinstalling Add-ons (enigmail)
Version: unspecified → 3.0

Updated

7 years ago
Summary: TB 3.0 Final hangs with 100 % CPU at restart after installing/deinstalling Add-ons (enigmail) → TB 3.0 Final hangs with 100 % CPU at restart/startup after installing/deinstalling Add-ons (enigmail)
Whiteboard: [add-on: enigmail]
You need to log in before you can comment on or make changes to this bug.