Closed Bug 533974 Opened 10 years ago Closed 10 years ago

Fennec takes 20+ seconds to start-up on nightlies

Categories

(Firefox for Android Graveyard :: General, defect, blocker)

Fennec 1.1
ARM
Maemo
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: aakashd, Unassigned)

References

Details

Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091209 Firefox/3.6b5pre Fennec/1.0b6pre


From the information that's noted so far:

- Via CLI, 4-5 seconds
- Via shortcut, 20+ seconds

I've been seeing a noticeable difference since 11/27 on nightly builds
Bug 533017 has a patch that speeds up startup to ~5seconds
Depends on: 533017
fixed, hopefully, by bug 533017
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I think I know what Jay is talking about here. Try these Steps to Reproduce:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091212 Firefox/3.6b5pre Fennec/1.0b6pre


1. Remove your profile from the device
2. Add a shortcut to Firefox onto the frontscreen
3. Start Fennec
4. Close Fennec
5. Open fennec again using the shortcut

There are times when Firefox doesn't load at all and other times it takes 20+ seconds on the 2nd time its loaded. The first time its loaded is consistently ~5 seconds.

I'm going to re-open this bug as I'm seeing this on today's nightly build.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
wfm
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → WORKSFORME
This is fixed on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091216 Firefox/3.6b5pre Fennec/1.0b6pre


a follow-up bug with the reported issue found in comment #3 is filed on bug 534982
Status: RESOLVED → VERIFIED
Resolution: WORKSFORME → FIXED
Component: Linux/Maemo → General
QA Contact: maemo-linux → general
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.