Second email address can be supplied by auto-completion look-up as first

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Composition
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Igor Velkov, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9.3a1pre) Gecko/20091120 SeaMonkey/2.1a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9.3a1pre) Gecko/20091120 SeaMonkey/2.1a1pre

After closing  Bug 447927 a second email addresses begins show in lookup list of address field mail composition window.
Often second address used very rare, but holds upper in proposal's list during lookup.

I thing correct behavior can be a count frecency for every email address string separately, or, at least (as a quick fix), always count that second address have a lower priority that first. 
Not in alphabetic order.

Reproducible: Always

Comment 1

8 years ago
Autocomplete (should!) use a popularity index for its suggestions and no alphabetic order. According to some reports here this index is sometimes lost or mismatched when migrating from SM1 to SM2. 

Or you might have used the secondary address more often than the primary one. I see this as invalid.
(Reporter)

Comment 2

8 years ago
If you use second address more often than first, and second showed as second always, you can, at least, just exchange first and second address order. 
If alphabet sort used, you can do nothing.

Comment 3

8 years ago
(In reply to comment #2)
> If you use second address more often than first, and second showed as second
> always, you can, at least, just exchange first and second address order. 
> If alphabet sort used, you can do nothing.

Ditto. Very annoying. At least make an option on how this works. Alphabetical or make it primary/secondary addresses.

Updated

8 years ago
Duplicate of this bug: 535736
Component: General → MailNews: Composition
QA Contact: general → mailnews-composition
Version: unspecified → Trunk

Comment 5

7 years ago
Igor, Ant, on trunk the primary email address should be first. Can you test with SeaMonkey 2.1b2pre? Thanks.
(Reporter)

Comment 6

7 years ago
Confirm.
WFM with
Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20101215 Firefox/4.0b9pre SeaMonkey/2.1b2pre - Build ID: 20101215062906

Comment 7

7 years ago
> Confirm.
> WFM with
> Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20101215 Firefox/4.0b9pre
> SeaMonkey/2.1b2pre - Build ID: 20101215062906

=> WORKSFORME on Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.