event date/time picked up incorrectly from winmail.dat attachment

RESOLVED DUPLICATE of bug 454705

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED DUPLICATE of bug 454705
9 years ago
8 years ago

People

(Reporter: ahmadjamal00, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.33 Safari/532.0
Build Identifier: TB 3.0b4

An email with a winmail.dat attachment was received. dragging this onto the today pane events area popped open the new event box, but with incorrect start-end times. LookOut was enabled, and the decoded ics file had the correct start/end time... 

Reproducible: Always

Steps to Reproduce:
1.Receive invite as winmail.dat.
2.Drag to today pane events area. 
Actual Results:  
TB popped open the new event box, but with incorrect start-end times.

Expected Results:  
The start and end time should be picked up correctly. If winmail.dat is not supported, then drag should be meaningless. This half was functionality is not correct.
(Reporter)

Comment 1

9 years ago
Created attachment 417085 [details]
screenshot of open new event box with incorrecly picked up times
Component: General → E-mail based Scheduling (iTIP/iMIP)
Product: Thunderbird → Calendar
QA Contact: general → email-scheduling
I don't know LookOut. Lightning supports only event invitations received via iTIP/iMIP protocol. In that case you'll see the Accept/Decline buttons in the header pane. I don't think it reads anything from some winmail.dat file.

Converting an email message into an event doesn't parse the message content yet (see Bug 403222). It only creates a new event with the message title and text as title and description. Start date/time is automatically set to the next hour, the end date/time is set according to your preferences.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454705
You need to log in before you can comment on or make changes to this bug.