Context window does not contain spell check entries when opened with shortcut shift-F10 instead of a right click in text mode

RESOLVED DUPLICATE of bug 346930

Status

--
minor
RESOLVED DUPLICATE of bug 346930
9 years ago
9 years ago

People

(Reporter: kloor68373, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

On Windows I can open context menus by shift-F10 keystrokes instead of a right mouse click. But the context menu opend in this way does not contain spell check entries like proposals for correct spelling. Works well in HTML compose window

Reproducible: Always

Steps to Reproduce:
1. Create a new mail *in text mode*
2. Mistype a word and leave the cursor within this word
3. Press shift-F10 to open context menu
4. Close context menu 
5. Press right mouse button to open context menu

Actual Results:  
spell check entries (proposals and spell check commands) are present in the context menu on step 5 but missing on step 3

Expected Results:  
spell check entries must always be present when the cursor is within a mistyped word and context menu is open, regardless of the way the context menu is opened

This behaviour exists in firefox too, but as an infrequent error. i will report it as soon as i found out the preconditions for the error to come out.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 346930
You need to log in before you can comment on or make changes to this bug.