Closed Bug 534218 Opened 13 years ago Closed 12 years ago

Changing sync direction from outdated clients loses client/server data

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: Mardak, Assigned: Mardak)

References

Details

(Keywords: dataloss)

Attachments

(1 file)

This means a client might clear itself before realizing remoteSetup would have prevented the sync.
Flags: blocking-weave1.0+
This isn't awesome, but the fix is doesn't seem low-risk, and we haven't had many (any?) problems yet, so moving to 1.1.
Flags: blocking-weave1.1+
Flags: blocking-weave1.0-
Flags: blocking-weave1.0+
Target Milestone: 1.0 → 1.1
Assignee: nobody → edilee
Target Milestone: 1.1 → 1.2
Assignee: edilee → nobody
Flags: blocking-weave1.2+ → blocking-weave1.2-
Target Milestone: 1.2 → 1.3
Flags: blocking-weave1.3+
Keywords: dataloss
Assignee: nobody → edilee
Blocks: 546320
Summary: sync calls wipeLocal before remoteSetup → sync calls wipeClient before remoteSetup
Summary: sync calls wipeClient before remoteSetup → Changing sync direction from outdated clients loses client/server data
Duplicate of this bug: 546320
Attached patch v1Splinter Review
Attachment #439083 - Flags: review?(mconnor)
Attachment #439083 - Flags: review?(mconnor) → review+
http://hg.mozilla.org/labs/weave/rev/f6525ff92a62
Check remoteSetup first to determine if we're okay to sync before wiping client/remote. Additionally only wipe enabled engines instead of everything.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: 1.3 → 1.3b1
Blocks: 563989
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.