recent files menu never updates

VERIFIED FIXED

Status

()

Core
Editor
P2
major
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Kathleen Brade, Assigned: Kathleen Brade)

Tracking

({pp, regression})

Trunk
PowerPC
Mac System 8.6
pp, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][p:2][rtm NEED INFO])

(Assignee)

Description

17 years ago
This may be Mac-specific (?).
In the editor, the recent files menu doesn't update.

Steps to reproduce:
  Open a file in Composer (fileA)
  Open another file in Composer (fileB)
  Switch back to window with fileA
  Check Recent Pages menu

I expect that fileB will be listed first in the Recent Pages menu.
Instead, fileB isn't shuffled to the proper location or added to the menu at all 
(if it hadn't been opened before).

Chris--is it possible that the menu isn't rebuilding itself in the mac menu code?  
If that's true, does that mean the bookmarks menu isn't updating itself after 
being edited?  Or mail folders listed in a menu?

Can anyone reproduce this on Linux or Windows?
(Assignee)

Updated

17 years ago
Keywords: nsbeta3, regression, rtm
Target Milestone: --- → M19

Comment 1

17 years ago
This was working last time I tested it on Windows (a few days ago)
I know there's been problems just on Mac
Target Milestone: M19 → M18

Comment 2

17 years ago
tested this using win98 on build 2000092005 comm build and it works correctly.
Asking Sujay to check it out on linux
(Assignee)

Comment 3

17 years ago
This appears to be Mac-specific.  I can't reproduce it on my Linux build.  Ryan 
can't reproduce it on his Windows build.
Keywords: pp

Comment 4

17 years ago
Kathy, can you work on this one? On my mac the list is corrupted and unusable
Assignee: cmanske → brade
Severity: normal → major
Keywords: rtm
Priority: P3 → P2
Whiteboard: [nsbeta3+][p:2]
Target Milestone: M18 → M19

Comment 5

17 years ago
Should be fixed now...
(Assignee)

Comment 6

17 years ago
this is fixed (thanks saari!)
I do get a new assertion in my mozilla debug build:
 ###!!! ASSERTION: Not implemented: '0' file nsMenu.cpp line 477
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

17 years ago
Status: RESOLVED → REOPENED
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Resolution: FIXED → ---

Comment 7

17 years ago
REopening because I don't see it working on all platforms now..

simply follow the above testcase...

Steps to reproduce:
  Open a file in Composer (fileA)
  Open another file in Composer (fileB)
  Switch back to window with fileA
  Check Recent Pages menu


I do not see File 1 and File 2 in either of the Recent page menus
for these files on ANY platform..

I'm using 9/29 branch build.

Updated

17 years ago
Keywords: rtm
Whiteboard: [nsbeta3+][p:2] → [nsbeta3+][p:2][rtm+ NEED INFO]

Comment 8

17 years ago
commonly used feature, is very visible, fix is low-risk

Kathy, please follow the checkin rules -- get a patch to fix the problems, get 
it super-reviewed, get module owner approval. The reviewer and module owner must 
make an entry in the bug, once all of that is done, remove the NEED INFO in the 
rtm+ block. I will then pop it to pdt for approval.
(Assignee)

Comment 9

17 years ago
I can't reproduce this bug on Linux (trunk) or Macintosh (trunk or branch)

Sujay--can you help out with this one?  What builds are people using to see this 
bug?  When did this break?

Everyone--remember, you do *NOT* see the name of the file currently being edited 
in the Recent Files menu (as spec'd).

Comment 10

17 years ago
PDT agrees [rtm need info] until patch and code reviews are available.
Whiteboard: [nsbeta3+][p:2][rtm+ NEED INFO] → [nsbeta3+][p:2][rtm NEED INFO]

Comment 11

17 years ago
ok I wasn't aware of the spec. its fine....this was the issue.

-remember, you do *NOT* see the name of the file currently being edited 
in the Recent Files menu (as spec'd).
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
verified in 9/29 build.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 13

17 years ago
I don't think this was ever verified as being a problem on any platform except 
Macintosh so changing platform/OS back.

Thanks Sujay for verifying...
OS: All → Mac System 8.6
Hardware: All → Macintosh
You need to log in before you can comment on or make changes to this bug.