Last Comment Bug 534322 - PageInfo Dialog is too short
: PageInfo Dialog is too short
Status: RESOLVED FIXED
[SeaMonkeyTestday]
:
Product: SeaMonkey
Classification: Client Software
Component: Page Info (show other bugs)
: SeaMonkey 2.0 Branch
: x86 Windows XP
: -- normal (vote)
: seamonkey2.1a3
Assigned To: Philip Chee
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-11 15:30 PST by Kevin Brosnan
Modified: 2010-07-27 01:33 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
screen shot of the issue (10.46 KB, image/png)
2009-12-11 15:30 PST, Kevin Brosnan
no flags Details
PageInfo in Minefield (37.96 KB, image/png)
2009-12-11 17:47 PST, Philip Chee
no flags Details
Patch v1.0 change height to 36em. (1.19 KB, patch)
2010-07-07 02:11 PDT, Philip Chee
neil: review+
neil: superreview+
Details | Diff | Splinter Review

Description Kevin Brosnan 2009-12-11 15:30:00 PST
Created attachment 417185 [details]
screen shot of the issue

The vertical height of the page info is too short. This causes problems with expanding and shrinking boxes in page info such as the general tab's meta tags display. This is on a clean profile, started, selected view > page info.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091206 SeaMonkey/2.0.1
Comment 1 Philip Chee 2009-12-11 17:47:50 PST
Created attachment 417214 [details]
PageInfo in Minefield

Confirmed. Minefield/Firefox 3.7a doesn't seem to have this problem.
Comment 2 neil@parkwaycc.co.uk 2009-12-15 16:39:28 PST
I don't want to overdo it, but we could probably safely bump up the dimensions from 100ch×30em to 100ch×35em or 100ch×36em?
Comment 3 Philip Chee 2009-12-25 03:06:43 PST
WindowsXP/SP2 here with a screen resolution of 1280x800.

At 100ch×36em the computed CSS width/height of the window element is 601px by 396px. The xul attributes are width=609 height=427
Comment 4 Philip Chee 2010-07-07 02:11:36 PDT
Created attachment 456245 [details] [diff] [review]
Patch v1.0 change height to 36em.

Bug 534322 PageInfo Dialog is too short

> neil@parkwaycc.co.uk      2009-12-15 16:39:28 PST
> 
> I don't want to overdo it, but we could probably safely bump up the dimensions
> from 100ch×30em to 100ch×35em or 100ch×36em?

> Philip Chee      2009-12-25 03:06:43 PST
> 
> WindowsXP/SP2 here with a screen resolution of 1280x800.
> 
> At 100ch×36em the computed CSS width/height of the window element is 601px by
> 396px. The xul attributes are width=609 height=427

36em seems to be a reasonably conservative choice so here it is.
Comment 5 neil@parkwaycc.co.uk 2010-07-20 06:58:07 PDT
Comment on attachment 456245 [details] [diff] [review]
Patch v1.0 change height to 36em.

I think we could even take it up to 38em if you prefer, but no more.
Comment 6 Philip Chee 2010-07-20 08:35:42 PDT
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/62d2961e7184

Note You need to log in before you can comment on or make changes to this bug.