Order of status/task/component bar icons for suite components is different in the MailNews standalone message window

RESOLVED FIXED in seamonkey2.1a1

Status

SeaMonkey
UI Design
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Rolf Pedersen, Assigned: InvisibleSmiley)

Tracking

({fixed-seamonkey2.0.3})

SeaMonkey 2.0 Branch
seamonkey2.1a1
fixed-seamonkey2.0.3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.4) Gecko/20091129 Mandriva/2.0-69.1mib2010.0 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.4) Gecko/20091129 Mandriva/2.0-69.1mib2010.0 SeaMonkey/2.0

At the bottom left of the window, the icons are, from left to right, "Browser", "Mail & Newsgroups", "Composer", "Address Book", "IRC Chat" in all windows except the standalone message window.  There, it is "Composer", "Address Book", "IRC Chat", "Mail & Newsgroups", "Browser".  

A comparison of a message window positioned above a browser window is here: http://dl.dropbox.com/u/1286780/status_icon5.png

I see the same using the Default Theme 1.0 and Pinball 2.0.2.  More screenies, reports for other OS and architecture, as well as mistaken reports comparing the "Mail" window, can be seen here: http://forums.mozillazine.org/viewtopic.php?f=40&t=1636965&start=0

On October 11, this was reported here: http://groups.google.com/group/mozilla.support.seamonkey/browse_thread/thread/2e2e7ce72ac13d81



Reproducible: Always

Steps to Reproduce:
1.Switch from any other component window to the standalone message window.
2.Observe different icon order.
3.
Actual Results:  
Order of status bar icons in the standalone message window is different, leading to a bit of ergonomic confusion/difficulty

Expected Results:  
Icon order should be consistent across windows, so not to have to think unnecessarily.
(Reporter)

Updated

8 years ago
Version: unspecified → SeaMonkey 2.0 Branch
(Assignee)

Comment 1

8 years ago
Confirming on WinXP with SM 2.0.2pre and a non-standard theme.

For me DOMI shows the order:
#mini-comp, #mini-addr, #mini-irc, #mini-mail, #mini-nav below #component-bar
even though
#minicomp  has insertafter=mini-mail
#mini-addr has insertafter=mini-comp
#mini-irc  has insertafter=mini-addr,mini-comp,mini-aim,mini-nav
#mini-mail has position=2
(#mini-nav has neither insertafter nor position)

Mnyromyr, do you have an idea?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Summary: Order of status bar icons for suite components is different in the standalone message window → Order of status/task/component bar icons for suite components is different in the MailNews standalone message window

Comment 2

8 years ago
Hint, look at the order of the xul-overlays (mini-* elements are in mailTasksOverlay.xul/tasksOverlay.xul files) in the two files messenger.xul and messageWindow.xul
(Assignee)

Comment 3

8 years ago
Created attachment 417257 [details] [diff] [review]
reorder overlays [checkin: comment 5]

(In reply to comment #2)
> Hint, look at the order of the xul-overlays (mini-* elements are in
> mailTasksOverlay.xul/tasksOverlay.xul files) in the two files messenger.xul and
> messageWindow.xul

Sharp eye! :-)

Patch applies cleanly on branch as well.
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #417257 - Flags: superreview?(neil)
Attachment #417257 - Flags: review?(mnyromyr)
Attachment #417257 - Flags: approval-seamonkey2.0.2?

Updated

8 years ago
Attachment #417257 - Flags: approval-seamonkey2.0.2? → approval-seamonkey2.0.2+

Comment 4

8 years ago
Comment on attachment 417257 [details] [diff] [review]
reorder overlays [checkin: comment 5]

It's actually caused by the relative ordering of mailWindowOverlay (which contains the definition of the component bar) and tasksOverlay (which adds the navigator icon). If tasksOverlay is parsed first, it can't find where to add the icon, and so that is deferred, but then the overlays that dynamically overlay tasksOverlay get added after all the static overlays get processed, allowing them to overlay the component bar first time around. Then a second pass finds a home for the navigator icon.
Attachment #417257 - Flags: superreview?(neil) → superreview+

Updated

8 years ago
Attachment #417257 - Flags: review?(mnyromyr) → review+
(Assignee)

Comment 5

8 years ago
Comment on attachment 417257 [details] [diff] [review]
reorder overlays [checkin: comment 5]

http://hg.mozilla.org/comm-central/rev/7535b645c711
http://hg.mozilla.org/releases/comm-1.9.1/rev/d80e1f09fc77
Attachment #417257 - Attachment description: reorder overlays → reorder overlays [checkin: comment 5]
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: fixed-seamonkey2.0.2
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a1
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.8pre) Gecko/20100104 Lightning/1.0b2pre SeaMonkey/2.0.2pre - Build ID: 20100104000459

I VERIFY that in this nightly, the sequence of icons at left of the status bar is Browser - Mail & Newsgroups - Composer - Address Book - IRC Chat, even in the standalone Message window.

I cannot check Windows or Mac.
You need to log in before you can comment on or make changes to this bug.