shockwave movies redraw improperly on mac(nsbeta3 rtm)

VERIFIED DUPLICATE of bug 54962

Status

()

P1
critical
VERIFIED DUPLICATE of bug 54962
19 years ago
18 years ago

People

(Reporter: kcunningham, Assigned: peterl-retired)

Tracking

({regression, shockwave})

Trunk
PowerPC
Mac System 8.6
regression, shockwave
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 (Macintosh; U; PPC)
BuildID:    2000081721

The movies will be cut off or overlap frames, all sorts of odd bounding issues. 
http://www.shockwave.com displays the behavior as well.						
	

Reproducible: Always
Steps to Reproduce:
1.install shockwave on mozilla milestone 17 or NS6pr2 on Mac 8.6
2.goto http://poppy.macromedia.com/netlanski/
3.click any link to a shockwave movie


Actual Results:  							The movies are cut off or 
have overlapping boundaries, particularly noticable when you resize the wondow

Expected Results:  	All of the movie should be visible and in it's proper place 
not overflowing into another frame						
Keywords: rtm, nsbeta3 shockwave)
Setting to P1 as Macromedia is a high profile partner, and Shockwave is the #4 
most widely-used plug-in in web content per Hotbot, and 
http://www.shockwave.com/ is a very high profile site these days, with millions 
of registered users and high daily traffic. Also, this bug is blocking further 
testing by their QA staff, so we don't know how many other more serious bugs are 
yet-uncovered because further testing is blocked by this. Nominating for nsbeta3 
and rtm consideration.
Keywords: correctness, nsbeta3, rtm, shockwave
Priority: P3 → P1
I can't confirm this now, but lowering to critical, this doesn't block the 
browser from working.
Severity: blocker → critical

Comment 3

19 years ago
This just got fixed with peter's fix to some other bug. Verified on mac 
commercial br build 2000092911.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 4

19 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
From Meredith Tomlin: Kelly Cunningham retested this issue on 10/5/00 (Netscape 
6 (mozilla) displays wacky redraw embed issues with SW8.5 and SW8 on mac) with 
nS6pr3 and found it to still be occuring.

Comment 6

18 years ago
Yes, This has again stopped working. I rechecked with the 10/05 build with SW 
8.0 on mac. REOPENING.
Status: VERIFIED → UNCONFIRMED
Resolution: FIXED → ---

Comment 7

18 years ago
fyi : This is just for shockwave movies and not flash.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: shockwave and flash movies redraw improperly on mac(nsbeta3 rtm) → shockwave movies redraw improperly on mac(nsbeta3 rtm)

Comment 8

18 years ago
assign:peterl
Assignee: av → peterl

Comment 9

18 years ago
Can someone attach a screen shot?

I tried this with the changes in my tree for bug 54962 and I don't see it. 
Marking as a depends on 54962.
Status: NEW → ASSIGNED
Depends on: 54962

Comment 10

18 years ago
For me, a blank space appears and nothing draws. The movie is not visible at 
all. This was working somewhere between 09/29 tp 10/05. kcunningham, do you see 
the same behaviour? Thx
                                                                                 

Comment 11

18 years ago
Hm...looks like a regression. Chris Petersen reported bug 56120 which has the 
same time frame as this. Wonder if they are related. Does a reload or resize fix 
the problem?

I have a report from CVS on the changes made in this time frame but I haven't 
had a chance to go through them.
Keywords: regression

Comment 12

18 years ago
nope, reload or resize does not work.

Comment 13

18 years ago
I'm sorry, I'm very confused. I just tried the movies on poppy with the 10/10 
nightly from Mozilla on the Mac with 8.0 and all the movies look fine. Tried the 
games at shockwave.com and they work (kinda fun too!)

Can I get a specific test case (url) and/or a screen shot?  Please also specify 
what build you are using.

Comment 14

18 years ago
From the screen shot that I got from kcunningham, I notied the problem was due
to sizing the window small. This is bug 54962 and the patch for this has already
been checked into the branch.

Comment 15

18 years ago
This looks very much like bug 54962 and the patch for this has already been
checked into the branch.

Comment 16

18 years ago
Yes, I can see this working fine in the mac branch build 2000101608. Marking 
FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED

Comment 17

18 years ago
or shud I have kept this OPEN till the fix is in the trunk too ? 

Comment 18

18 years ago
Just for the record, this hasn't been checked into the trunk yet. Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Marking DUP of 54962. When 54962 is in on the trunk, we should verify that both
54962 and 53437 are indeed fixed.

*** This bug has been marked as a duplicate of 54962 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 20

18 years ago
verified working fine on mac branch and trunk 0126.
You need to log in before you can comment on or make changes to this bug.