Closed Bug 534414 Opened 11 years ago Closed 11 years ago

[Regression] FormFill: Cannot Span direction fields on Google Maps

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED
fennec1.0

People

(Reporter: aakashd, Assigned: vingtetun)

Details

Attachments

(2 files)

Build Id:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091211 Firefox/3.6b5pre Fennec/1.0b6pre

Note: The began happening on the 12/9 nightly builds for 1.9.2. The bugs moved to resolved:fixed in that timeframe were bug 532686 and bug 524501

Steps to Reproduce:
1. Go to maps.google.com
2. Click on "Get Directions"
3. Click on the first address field

Actual Results:
The next and previous buttons are grayed-out and the user can't span to any other elements.

Expected Results:
The next and previous buttons are active and usable and the user should be able to span between the buttons and fields.
I'm seeing this on bugzilla's advanced search page as well.
Severity: major → blocker
This is also happening on okcupid.com and seems to be happening on 1.9.2 and working fine on trunk on build:

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091214 Firefox/3.7a1pre Fennec/1.0b5
Attached patch PatchSplinter Review
There is no reason for this patch...
Basically this patch did the same stuff as the existing code but it works...

In the old colde there is a a race condition somewhere : if i put a few dumps into the _getPrevious/_getNext loops the update of the disabled state of the buttons works.

I bet that's also the reason of bug 533970 where the only diff between ben's device and mine was the speed of the internet connection and he was able to repro the bug while i was unable.
Assignee: nobody → 21
Attachment #417653 - Flags: review?(mark.finkle)
Comment on attachment 417653 [details] [diff] [review]
Patch

>+    let index = this._nodes.indexOf(this._currentElement);
>+    return this._nodes[--index] || null;

.indexOf will return -1 if it fails to find the element. I'm not sure I like trying this._nodes[-2] first. How about

      return (index != -1 ? this._nodes[--index] : null);

>+    let index = this._nodes.indexOf(this._currentElement);
>+    return this._nodes[++index] || null;

How about:

      return (index != -1 ? this._nodes[++index] : null);

r+ with those changes
Attachment #417653 - Flags: review?(mark.finkle) → review+
pretty important. affecting many webpages.

pushed:
https://hg.mozilla.org/mobile-browser/rev/e5085277903a
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → RC
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091217 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091217 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
Flags: in-litmus?
litmus testcase id 9793 has been created to regression test this bug.
Flags: in-litmus? → in-litmus+
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.